Fordmods Logo

AU2 Fairmont Horn and Cruise Control not working? 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: AU2 Fairmont Horn and Cruise Control not working?
Posted: Sun Mar 13, 2011 9:20 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 6

Joined: 16th Jul 2010

Ride: AUII Fairmont Ghia

Location: Sunshine Coast
QLD, Australia

Hey guys,
So i posted a topic a few weeks ago explaining that my cruise control had stopped working. Yesterday my horn also stopped working. Would anybody happen to know where the fuse/relay is for the horn? I figured it was in the box beside the battery but havent been able to find any diagram pointing out which relay i needed to look at.

Any help would be appreciated. Thanks guys.
Top
 Profile  
 
 
 Post subject: Re: AU2 Fairmont Horn and Cruise Control not working?
Posted: Wed Mar 23, 2011 10:25 pm 
Parts Gopher
Offline

Posts: 57

Joined: 16th Apr 2005

Location: Melbourne
VIC, Australia

Could it be the clock spring contacts on your steering wheel?

edit: saw the other thread, if CC engages but you can't actually use it (ie, the controls on your steering wheel don't work) then it does sound like it could be that...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:04 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names