Fordmods Logo

BA heater not working 

 

Page 1 of 2 [ 18 posts ] Go to page 1, 2  Next

 
 Post subject: BA heater not working
Posted: Sat Jul 02, 2011 12:05 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 1953

Joined: 1st Feb 2006

Gallery: 25 images

Ride: BA on gas. EL on gas. XF on gas.

Location: Greenacres/Adelaide
SA, Australia

My brother has a BA ute and sedan.
Both cars have had their heaters stop working.
The A/C and fans are working, just no heat.
Any ideas?

 

_________________

Member Number 8804
Image

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Sat Jul 02, 2011 12:48 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 1507

Joined: 14th Aug 2009

Gallery: 12 images

Ride: BA XT V8

Location: Gosnells, Perth
WA, Australia

yea my BA heater isnt too happy eitha.
you have to fiddle with the hot/cold mixer thing till the heat starts commin out.
now that its got hot air commin out i just leave it on hot so i dont have to struggle with it anymore.

no idea why its like this but i would suspect some cheap poor design by the good fellas at ford have caused this problem.

 

_________________

BA XT V8. Ice Mint. 18" Speedys. XR6T LSD. Full Pacemaker twin 2 1/2inch Stainless Steel system. Custom CAI. Black XR interior with white trimming. Powerbond underdrive kit 25%.
13.65@102mph. 2800 hi-Stall.
230RWKW@5250 rpm. 625NM.

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Sat Jul 02, 2011 6:30 pm 
Tyre Shredder
Offline
User avatar

Age: 42

Posts: 363

Joined: 7th Feb 2007

Ride: BLOWN 347 EB GT/ BF XR6 TURBO

Power: 345 rwkw

Location: eastern creek
NSW, Australia

it is the blendor motor rod in the heater box have to pull dash out to fix it is a long white plastic rod right behind the radio

 

_________________

MY CAR PLZ TAKE A LOOK forums/xtt909-update-t66227.html

DAZFAB MEMBERS ,,,,DAZZLE, EBI347, TERRORISTGHIA, TROYMAN ,SWC, XTT909

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Sat Jul 02, 2011 8:23 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 862

Joined: 8th May 2005

Ride: BA Wagon Turbo, Ba Fairlane G220

Location: Colac
VIC, Australia

Ok sorry to hijack your thread but I sort of have the same problem with the missus dual zone the drivers side blows hot air but the passenger side only blows cold. Any idea what that would be?

 

_________________

Congo Green Ba Wagon With F6 6 Speed Manual Driveline.

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Mon Jul 04, 2011 8:42 pm 
Tyre Shredder
Offline
User avatar

Age: 42

Posts: 363

Joined: 7th Feb 2007

Ride: BLOWN 347 EB GT/ BF XR6 TURBO

Power: 345 rwkw

Location: eastern creek
NSW, Australia

same deal i think as they run to seperate motors with a pivot point in the middle to seperate them

 

_________________

MY CAR PLZ TAKE A LOOK forums/xtt909-update-t66227.html

DAZFAB MEMBERS ,,,,DAZZLE, EBI347, TERRORISTGHIA, TROYMAN ,SWC, XTT909

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Tue Jul 05, 2011 10:20 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 862

Joined: 8th May 2005

Ride: BA Wagon Turbo, Ba Fairlane G220

Location: Colac
VIC, Australia

XTT909 wrote:
same deal i think as they run to seperate motors with a pivot point in the middle to seperate them


Sweet thanks mate will check it out.

 

_________________

Congo Green Ba Wagon With F6 6 Speed Manual Driveline.

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Sat Sep 10, 2011 10:22 pm 
Fordmods Newbie
Offline

Age: 49

Posts: 2

Joined: 12th Jul 2010

Ride: ford fairlane

Location: brisbane
QLD, Australia

Hi everybody,
just on the subject of the dual zone blend doors not working due to broken spindle or snapped blend door hinges.......my 04 fairlane started with passenger side losing heat totally, then drivers side losing heat. spent days researching with everyone saying its a dash out job. i have just found this link to a jeep site with the same prob and a solution other than dash out. It involves taking out glove box and motor drive for the him box....mayb the blower motor as well and cutting a hole in the shell of the him box. check it out, i,m going to try it in the next few days hopefully.

http://www.jgcparts.com/JeepHeater.html ... 4god6x66tw
Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Mon Sep 12, 2011 7:42 pm 
Tyre Shredder
Offline
User avatar

Age: 42

Posts: 363

Joined: 7th Feb 2007

Ride: BLOWN 347 EB GT/ BF XR6 TURBO

Power: 345 rwkw

Location: eastern creek
NSW, Australia

dude it takes 25 mins to take ba dashes out if u need help pm an can do it for you dont cut your heater box up :x :x :x

 

_________________

MY CAR PLZ TAKE A LOOK forums/xtt909-update-t66227.html

DAZFAB MEMBERS ,,,,DAZZLE, EBI347, TERRORISTGHIA, TROYMAN ,SWC, XTT909

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Mon Sep 12, 2011 10:07 pm 
Fordmods Newbie
Offline

Age: 49

Posts: 2

Joined: 12th Jul 2010

Ride: ford fairlane

Location: brisbane
QLD, Australia

Ok checked out the keyhole surgery idea and cant access the area where the blend doors are anyway. performed a heater bypass and recirculated the coolant/hot water back to the motor. the reason for this was due to my blend doors being either stuck closed on one side and stuck open on the other. ( missus's side having icy cold beautiful a/c but no heat and me having hot and beautiful heater but luke warm a/c). All this variety with the dual zone set to same temp. XTT909, are you in brissy and how much would you charge to do it?
Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Tue Sep 13, 2011 10:48 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 1953

Joined: 1st Feb 2006

Gallery: 25 images

Ride: BA on gas. EL on gas. XF on gas.

Location: Greenacres/Adelaide
SA, Australia

XTT909 wrote:
dude it takes 25 mins to take ba dashes out if u need help pm an can do it for you dont cut your heater box up :x :x :x

More info please, I may have 2 BA's to do.....

 

_________________

Member Number 8804
Image

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Fri Sep 16, 2011 9:58 pm 
Tyre Shredder
Offline
User avatar

Age: 42

Posts: 363

Joined: 7th Feb 2007

Ride: BLOWN 347 EB GT/ BF XR6 TURBO

Power: 345 rwkw

Location: eastern creek
NSW, Australia

if ya serious pm me your email and will send photos of the important areas

 

_________________

MY CAR PLZ TAKE A LOOK forums/xtt909-update-t66227.html

DAZFAB MEMBERS ,,,,DAZZLE, EBI347, TERRORISTGHIA, TROYMAN ,SWC, XTT909

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Wed Sep 28, 2011 5:04 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 2

Joined: 5th Jul 2010

Ride: 2003 ba xr 6 5 speed n/a

Location: greta
NSW, Australia

i heard a loud crack the other day and now have no heater. i managed to pull the bottom half of the glove box side and and some of the dash in that area enough to see that the shaft has snapped. i can't seem to get the dash apart anymore, think i'm just worried bout breaking something. if anyone has any tips on dash removal and also on the heater box part of the job that'd be a massive help!
Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Wed Sep 28, 2011 7:01 pm 
Stock as a Rock
Offline

Age: 26

Posts: 137

Joined: 8th Apr 2010

Ride: Dohc el futura, ea falcon

Location: horsham
VIC, Australia

u need to take ur centre console out there is one bolt behind that.. theres a bolt down next to where a clutch peddle would be.. there two on each side of the dash they have covers over them.. and one each side that u open the doors to get too.. all are size ten spanners/sockets
Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Thu Oct 13, 2011 6:28 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 862

Joined: 8th May 2005

Ride: BA Wagon Turbo, Ba Fairlane G220

Location: Colac
VIC, Australia

So did anyone end up getting any pics for this?

 

_________________

Congo Green Ba Wagon With F6 6 Speed Manual Driveline.

Top
 Profile  
 
 
 Post subject: Re: BA heater not working
Posted: Sun Oct 23, 2011 9:38 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 2

Joined: 5th Jul 2010

Ride: 2003 ba xr 6 5 speed n/a

Location: greta
NSW, Australia

i'm keen for pics as well still if anyone has them.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 18 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 2:04 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names