Fordmods Logo

BA Ute noisy wiper motor or linkages 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: BA Ute noisy wiper motor or linkages
Posted: Mon Sep 03, 2012 11:45 pm 
Fordmods Newbie
Offline

Posts: 10

Joined: 18th Sep 2011

Location: southwest
WA, Australia

Hi Guys,
I have a `04/`05 BA Falcon one tonne tray back ute and my wiper motor or linkages are making a terrible noise when I turn them on and it continues the whole time they are on. I put twin blade wipers on about 2 - 3 months ago but the noise has only started in the last week. As the rain slows and the screen gets drier they labour a little bit which I guess is because of the twin blades. Obviously they screech a bit too due to less rain on the screen. When there is enough moisture on the screen they work fine and have not lost speed but the noise is still there. I`m going to go back to single blades to see if that helps and I`ll check the linkages etc on the week end to see if a bit of lubrication might help (Good or Bad idea? Don`t want to foul my widscreen?) but I`m just wondering if any one knows whether or not it sounds like the motor might be on it`s way out. If it sounds like the motor is on it`s way out is it worth putting in a second handy or just buy a new one? Any cost estimates if anyone knows for both cases would be appreciated. I do 160k`s daily to work and back and "Gina" has been a good, reliable ute (As i knew she would be upon purchasing 8-) ) plus I`m a pedantic bastard so this is doing my head in! (The noise, not Gina) Any wisdom would be appreciated. Cheers
Top
 Profile  
 
 
 Post subject: Re: BA Ute noisy wiper motor or linkages
Posted: Tue Sep 04, 2012 7:08 pm 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

shafts and linkages are normaly dry.use some graphite grease and work it in,ford wiper blades had a graphite in the rubber blade to glide over the glass,very slippery.have you cleaned the screen so it smooth and slippery,you will be surprised how much stuff sicks to it.

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
 Post subject: Re: BA Ute noisy wiper motor or linkages
Posted: Thu Sep 06, 2012 1:03 am 
Fordmods Newbie
Offline

Posts: 10

Joined: 18th Sep 2011

Location: southwest
WA, Australia

Thanks for the reply Hans.

I put new single "SCA Multi edge" wipers on yesterday and they work heaps better and a lot quieter than the twin blades but the awful noise is still the same. I haven`t cleaned the screen yet but i will as soon as i can. I`ll put some graphite grease on the parts you said but a quick question. Do you know if I have to remove the shafts and linkages out from the car to apply the graphite grease?
I realised after my post that the BA is a 2002 model as well.

Thanks again
Top
 Profile  
 
 
 Post subject: Re: BA Ute noisy wiper motor or linkages
Posted: Thu Sep 06, 2012 5:15 pm 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

Razzau wrote:
Thanks for the reply Hans.

I put new single "SCA Multi edge" wipers on yesterday and they work heaps better and a lot quieter than the twin blades but the awful noise is still the same. I haven`t cleaned the screen yet but i will as soon as i can. I`ll put some graphite grease on the parts you said but a quick question. Do you know if I have to remove the shafts and linkages out from the car to apply the graphite grease?
I realised after my post that the BA is a 2002 model as well.

Thanks again

leave the unit in the car and grease it,get a water hose and run water on the windscreen and run the wipers,may take 10 -20 min.to work the grease in,or stop and sqeeze more in.

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 5:15 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names