Fordmods Logo

blown globes on el cluster 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: blown globes on el cluster
Posted: Tue Nov 15, 2011 11:27 pm 
Getting Side Ways
Offline

Age: 29

Posts: 887

Joined: 13th Mar 2011

Gallery: 14 images

Ride: 1999 Ford AU1 Forte Wagon

Location: Morwell
VIC, Australia

hi i have a couple blown globes on my el cluster part of the speedo lights up n part of it doesnt also couple gauges dont lights up volts n fuel n also demister can i just take the bulbs n holders off my old ef cluster n plug them in?

 

_________________

1999 AU Forte Wagon Fairly Stock

Top
 Profile  
 
 
 Post subject: Re: blown globes on el cluster
Posted: Wed Nov 16, 2011 10:18 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Yes.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 8:38 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names