Fordmods Logo

Climate Control Display 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Climate Control Display
Posted: Mon Mar 28, 2005 6:32 pm 
Stock as a Rock
Offline

Age: 34

Posts: 118

Joined: 5th Nov 2004

Gallery: 5 images

Ride: BA XR6 Turbo

Location: Sydney
NSW, Australia

Hi!
The other day I noticed that the "OFF" text on the climate control was no there. I put the a/c on and it worked fine, but just no display.

Seems like an LED problem to me, but is there anything else that is could be?

Oh and how do I get behind there to fix it?

Thanks!

 

_________________

fast1

Top
 Profile  
 
 
Posted: Mon Mar 28, 2005 7:50 pm 
Getting Side Ways
Offline

Posts: 988

Joined: 4th Dec 2004

Ride: el faimont, dual fuel

Location: melbourne
VIC, Australia

my el did this a couple of weeks ago there was 3 parky bulbs behind it 1 for the screen and 2 for the buttons, the top one has prorly blown.
to get to it remove the coving arnd the head unit first, 2 screws behind ciggy tray for ef and back or 11 screw and a clip for el, and then the rest of the dash surrround, 2 screws under the boot button one on the other side 3 on top of your cluster and 2 next to head unit then 3 clips on the top left corner of the surround which u just yank the surround genly to get out, then theres 4 screws holding the climate control in.
double check that u get all the screws as this is just a guide.

 

_________________

why do u write in here.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 3:51 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names