Fordmods Logo

Constantly blowing cluster fuse on BA Fairlane 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Constantly blowing cluster fuse on BA Fairlane
Posted: Tue Jun 22, 2010 6:18 pm 
Fordmods Newbie
Offline

Posts: 16

Joined: 4th Feb 2005

Ride: XF Falcon

Location: Whyalla
SA, Australia

A few weeks back I took my Brother's 2003 BA Fairlane out for a drive, everything worked just as it should and I returned home, parked it up and locked the vehicle. The following day, it had no gauges on the instrument cluster, no indicators and the ICC no longer lights up. We could at that stage still hear the radio through the speakers though.

First thing to check was the fuses. We found that the fuse for the cluster was blown, but as soon as we replaced it, it blew straight away, even without having the keys in the ignition. So I them assumed that it must be something which is drawing power even when the accessories aren't turned on. But I can't pinpoint it.

The car will still start up and can be driven, you just don't have an ICC or any gauges and indicators. We have a spare combination switch, so we threw that in and it made no difference. I've unplugged the 5 looms under the ICC to isolate that, but still no difference, although the CD stacker was still making noises and that has been repaired once before.

I then called a bunch of Ford mechanics and picked their brains, a few of them suggested checking the trailer plug wiring. Upon inspection, the trailer plug was all corroded out and we thought we were on the right path, though after unplugging it all from inside the boot and taking the trailer plug off, it too made no difference.

We're not sure where else to try at this stage. We're going to get a bloke in to pull the entire ICC out and see if its the CD stacker, but thats all we have left to go on. I've been searching the forums for the last couple of weeks and found some about similar problems, but i've either tried everything suggested or something else isn't quite the same.

Any ideas?
Top
 Profile  
 
 
 Post subject: Re: Constantly blowing cluster fuse on BA Fairlane
Posted: Thu Jun 24, 2010 12:19 pm 
Getting Side Ways
Offline

Age: 27

Posts: 971

Joined: 18th Dec 2008

Ride: BA Futura

Location: Hobart
TAS, Australia

Since it blows the fuse straight away a diagnostic wouldn't show anything up about the problem, you might be better off to get it diagnosed by an auto electrician or by Ford.

But I would be making sure they had a set 'diagnose and quote' price, or at least a set price range before committing spending any money.

 

_________________

Image
DCII LTD V8 - leather - low k's
1978 XC '1/2' 500 project 302C
BA Futura wagon
P38 Range Rover HSE

Top
 Profile  
 
 
 Post subject: Re: Constantly blowing cluster fuse on BA Fairlane
Posted: Thu Jun 24, 2010 1:21 pm 
Fordmods Newbie
Offline

Posts: 16

Joined: 4th Feb 2005

Ride: XF Falcon

Location: Whyalla
SA, Australia

Don't have a local Ford service centre any more. Nearest one is 70kms away. Can't drive the car without any indicators or gauges really.

If we have no joy with the ICC being out of the picture then I guess its off to a local auto sparky.
Top
 Profile  
 
 
 Post subject: Re: Constantly blowing cluster fuse on BA Fairlane
Posted: Thu Jun 24, 2010 1:29 pm 
Getting Side Ways
Offline

Age: 22

Posts: 613

Joined: 13th Mar 2010

Ride: EF Falcon Monti

Location: Central Coast
NSW, Australia

I dont know if you or anyone has meantioned but have you made any new connections? and do the power windows work at all?

 

_________________

BANNED USER

Top
 Profile  
 
 
 Post subject: Re: Constantly blowing cluster fuse on BA Fairlane
Posted: Thu Jun 24, 2010 1:30 pm 
Fordmods Newbie
Offline

Posts: 16

Joined: 4th Feb 2005

Ride: XF Falcon

Location: Whyalla
SA, Australia

Nothing has been changed. Nothing added, nothing removed.

To be honest, I havn't checked the power windows yet. Will check after work.
Top
 Profile  
 
 
 Post subject: Re: Constantly blowing cluster fuse on BA Fairlane
Posted: Thu Jun 24, 2010 1:33 pm 
Getting Side Ways
Offline

Age: 22

Posts: 613

Joined: 13th Mar 2010

Ride: EF Falcon Monti

Location: Central Coast
NSW, Australia

Cause even though the power windows have their own C/B, something else could be shorting out thats related to them OR the main power line inside one of the doors may have been pinched and as a result, it is blowing fuses by trying to send power through ground which isnt good.

Does you interior lights work either?

 

_________________

BANNED USER

Top
 Profile  
 
 
 Post subject: Re: Constantly blowing cluster fuse on BA Fairlane
Posted: Thu Jun 24, 2010 1:55 pm 
Fordmods Newbie
Offline

Posts: 16

Joined: 4th Feb 2005

Ride: XF Falcon

Location: Whyalla
SA, Australia

I believe the interior lights worked fine until I unplugged the 5 connectors underneath the ICC.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 6:40 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names