Fordmods Logo

Dash squeaks... 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: Dash squeaks...
Posted: Mon Jul 07, 2008 7:21 pm 
Oompa Loompa
Offline

Posts: 20

Joined: 12th Aug 2006

Location: Brisbane
QLD, Australia

Hi everyone. Long, long, long time lurker to the forums.

I have an EL 'mont with a couple of really annoying squeaks.

The first is on the RHS of the dash right near the headlight switch. If I push the dash next to the switch it makes a squeak as I push in, and then again as it returns out. I have pulled the vent out and the coverplate of the dash off and sprayed buggery out of both places with silicon spray but I am obviously missing the spot as the b*** still squeaks. Is there a dash mounting point there anywhere that I am missing? Sort of right in behind the light switch?

The second annoyance is a rattle in my centre console to the right of the ciggie lighter - where the console joins the dash. The noise the rattle makes is like a bolt with washers that has come loose and the washers are rattling. How do I get in (underneath) the centre console to tighten what is loose?

Any help would be much appreciated as I have had both f*** noises to the back teeth.

Anyone able to help?
Top
 Profile  
 
 
Posted: Mon Jul 07, 2008 7:41 pm 
Stock as a Rock
Offline

Posts: 165

Joined: 21st Jan 2007

Ride: AU2 XR8

Location: darwin
NT, Australia

spray in some WD40, or even graphite powder.

my A/C vents rattle sometimes. i just lightly spray them with WD40 and problem gone. lasts about 6 months.

door/window mech on AU is also prone to rattling, also the rear bench seat fold-down hatch squeaks.

 

_________________

i wish to be a ring on a maidens hand so when she wipe herself i see the promised land.

Top
 Profile  
 
 
Posted: Mon Jul 07, 2008 7:45 pm 
Oompa Loompa
Offline

Posts: 20

Joined: 12th Aug 2006

Location: Brisbane
QLD, Australia

Yep done that with the silicon spray.

Just not sure where the dash mount point is - I'm pretty sure that's what's making all the noise.
Top
 Profile  
 
 
Posted: Mon Jul 07, 2008 10:14 pm 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

barrymcfysh wrote:
Yep done that with the silicon spray.

Just not sure where the dash mount point is - I'm pretty sure that's what's making all the noise.


what mount? (like what area is the squeak coming from) Graphite powder is the way

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
Posted: Tue Jul 08, 2008 5:30 am 
Smokin em up
Offline
User avatar

Posts: 231

Joined: 4th Jan 2008

Gallery: 1 images

Ride: EF Futura

Location: Melbourne
VIC, Australia

My EF's dash was squeaking badly a while ago. I took the better part of the dash off to install a trip computer and change a few of the LEDs in my dash display.

I put it all back together and tightened it right up and all the squeaks are now gone. Solid as a rock and quiet as the night.

Might sound stupid.... but have you tried tightening all the accessible dash mounting screws? There should be a few under the speedo area, a couple down by the centre console and a couple along the top too.

It did the trick for me.
Top
 Profile  
 
 
Posted: Tue Jul 08, 2008 9:46 am 
Oompa Loompa
Offline

Posts: 20

Joined: 12th Aug 2006

Location: Brisbane
QLD, Australia

Thanks for the replies guys.

The squeak is coming from the right of the headlight switch. If I push on the soft part of the dash it squeaks. I was thinking there must be some sort of anchoring point or dash mount there but I can't see anything when the vent is removed. Is there one there? If not, I'll make sure that all the ones I can find are tight
Top
 Profile  
 
 
Posted: Tue Jul 08, 2008 11:24 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

Heh, my EF dash squeaks in the same place and no, I can't fix it either!

The main dash bolts are right up near the base of the windscreen. Take off the uppermost dash panel cover and spray some stuf in there!

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
Posted: Thu Jul 10, 2008 6:03 pm 
Oompa Loompa
Offline

Posts: 20

Joined: 12th Aug 2006

Location: Brisbane
QLD, Australia

Thanks Mike, I'll give that a try and see how I go.

I found the source of the second rattle - the one I thought was to the right of the ciggie lighter. As it happens it was the 10mm bolt and washer that holds (I think) the back of the console to the black frame that the stereo is mounted to. For anyone else with this problem you need to remove stereo fascia to get to it. You can see the bolt (just) from the front and feel the back of it at the back of the console

One down, dash squeak to go!!
Top
 Profile  
 
 
Posted: Thu Jul 10, 2008 10:38 pm 
Getting Side Ways
Offline

Age: 29

Posts: 2563

Joined: 19th Feb 2007

Gallery: 21 images

Ride: 98 EL Futura

Power: 199 rwkw

Location: Lilydale
VIC, Australia

oh nice il be looking at this thread for sure i have the squeak in the same spots, il try find them when i get my car back

 

_________________

EL Futura: CVE head, Wolf V500, ICE Ignition and Coil, 36lb injectors, Walbro 255lb, Paci comps, 3" exhaust, T5, Harrop Truetrac with 3.9s. Now with 198.9rwkw, (~185rwkw and 13.80 @99.1mph) with more power to come

Top
 Profile  
 
 
Posted: Fri Jul 11, 2008 3:15 pm 
Oompa Loompa
Offline

Posts: 20

Joined: 12th Aug 2006

Location: Brisbane
QLD, Australia

Done and dusted!

Found the annoying dash squeak finally. I removed the dash pad extension panel and started pushing on the dash so that it made the noise. One of my dash mounting points (the one just in front of the drivers side tweeter) was broken - had snapped. I got my can of silicon spray and sprayed liberally in and around the bolt.

It's fixed the annoying squeak and I'm now weighing up whether to get the mount fixed - probably won't. There doesn't seem to be too much movement in the dash but I might have to spray it every few months to keep the noise at bay.

Hope this helps anyone else with this frustratingly annoying problem.

Cheers!
Top
 Profile  
 
 
Posted: Fri Jul 11, 2008 5:17 pm 
Getting Side Ways
Offline

Age: 29

Posts: 2563

Joined: 19th Feb 2007

Gallery: 21 images

Ride: 98 EL Futura

Power: 199 rwkw

Location: Lilydale
VIC, Australia

good find il try the same thing, is it somthing superglue could fix or?

Also mine did it after i got my suspension, may of been too firm and cracked somthing up in the dash area

 

_________________

EL Futura: CVE head, Wolf V500, ICE Ignition and Coil, 36lb injectors, Walbro 255lb, Paci comps, 3" exhaust, T5, Harrop Truetrac with 3.9s. Now with 198.9rwkw, (~185rwkw and 13.80 @99.1mph) with more power to come

Top
 Profile  
 
 
Posted: Sun Jul 13, 2008 4:28 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 2537

Joined: 5th Nov 2004

Gallery: 13 images

Ride: EFII Fairmont

Location: Perth
WA, Australia

Yeah I had the snapped retainer there as well. Happens to a lot of the EF/EL's. I've actually got 2 or 3 screws anchoring it through the metal part of the structure behind, a little to the left, right at the top edge of the plastic dash.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 2:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names