Fordmods Logo

EB CLUSTERS 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EB CLUSTERS
Posted: Sat May 10, 2008 4:10 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 10th May 2008

Location: wauchope
NSW, Australia

hi just wondering if any body can help me with an answer i have eb 11 gli
an i have updated the cluster to the fairmont cluster now thiers a problem with the fairmont trip not working. can i swap the gli trip which works fine , with the fairmont cluster, will the be any problems with the speedo( will it read true speed )
Top
 Profile  
 
 
Posted: Sat May 10, 2008 4:18 pm 
Getting Side Ways
Offline

Age: 31

Posts: 2337

Joined: 25th Apr 2008

Ride: Boxcar Love

Location: Brisbane
QLD, Australia

Do you mean just the little trip dial under the speedo? If so, its just a plastic type cog in the speedo that wears out. just swap in the GLI one and it'll be fine.

I'm 99% sure its the same part between them.

Andrew.

 

_________________

Commodore australia's favorite car??? What a load of s**t
Image

Top
 Profile  
 
 
 Post subject: EB CLUSTER
Posted: Sat May 10, 2008 4:55 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 10th May 2008

Location: wauchope
NSW, Australia

COULD I JUST SWAP THE SPEED & THE TRIP FROM THE GLI TO THE FAIRMONT CLUSTER AN WILL THE SPEEDO RUN JUST A IF IT WAS IN THE GLI CLUSTER ( THE SPEED ON THE SPEEDO SHOULD RUN THE SAME)
Top
 Profile  
 
 
Posted: Sat May 10, 2008 5:47 pm 
Getting Side Ways
Offline

Age: 31

Posts: 2337

Joined: 25th Apr 2008

Ride: Boxcar Love

Location: Brisbane
QLD, Australia

you should be able to put the whole speedo unit in, but i'm not entirely sure if the screws that hold it are the same, but with both clusters out, you can just double check.

The speed will be the same.

Andrew.

 

_________________

Commodore australia's favorite car??? What a load of s**t
Image

Top
 Profile  
 
 
 Post subject: EB CLUSTER
Posted: Sat May 10, 2008 11:52 pm 
Fordmods Newbie
Offline

Posts: 4

Joined: 10th May 2008

Location: wauchope
NSW, Australia

YEAH THANX ANDREW ,I ALL READY DONE THAT EVERY THING IS THE SAME AN FITS STRAIGHT IN. JUST ASKING BECAUSE IT SEEMS/ FEELS THAT I`M TRAVERLING SLOWER THAN THE SPEEDO IS READING.

TERRY
Top
 Profile  
 
 
Posted: Tue May 13, 2008 8:42 pm 
Oompa Loompa
Offline

Age: 47

Posts: 42

Joined: 1st Sep 2007

Ride: EBII Falcon GLi

Location: Rockingham
WA, Australia

Thankyou for the info guys as I have exactly the same problem with my EBII ( EB Fairmont cluster installed ).

 

_________________

EBII GLi sedan 4.0 MPEFI, high series head unit, C**k green, ABS, EB sedan 4.0 MPEFI, red, stock

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 6:07 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names