Fordmods Logo

eb v8 - odometer and trip counter not working 


Page 1 of 1 [ 3 posts ] 

 Post subject: eb v8 - odometer and trip counter not working
Posted: Wed Apr 30, 2008 11:54 pm 
Parts Gopher

Age: 39

Posts: 53

Joined: 10th Dec 2005

Gallery: 1 images

Ride: EF XR6

Power: 114 rwkw

Location: Glen Iris
VIC, Australia

Hi all,
not sure if this is a common problem but the odometer and trip counter have stopped working on the eb, high series cluster.
anyone had this problem and know how to fix.
cause it would be nice to see what the kms are like per tank without having to guess.



1992 EB II V8 S Pac Wagon
Everglade green
4 speed auto
EL GT rims
Lowered by TTF
Sound by Pioneer
Roof mounted DVD screen/player

Posted: Thu May 01, 2008 12:21 am 
Getting Side Ways

Age: 65

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

try this ... uster+gear and paulmac sells the gear.




Posted: Thu May 01, 2008 12:34 am 
Technical Contributor

Age: 49

Posts: 3227

Joined: 12th Feb 2007

Gallery: 10 images

Ride: Falcon

Power: 113 rwkw

Location: your mums
NSW, Australia

i had the same problem with my EB v8 cluster and getting the little tiny Cluster cog from Paulmac and benj fixed it now it all works.

the old little cog is rubber and breaks easy, with the one you can get from Paulmac or Benj its a hard plastic and will out last the cluster, you will end up with the trip and the odo working when you change it.




Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 7:16 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names