Fordmods Logo

EF-EL speedo cluster 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EF-EL speedo cluster
Posted: Mon Nov 28, 2011 8:02 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 552

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Brisbane
QLD, Australia

hey guys just wondering how do i get the oil guage and battery guage on GLi speedo cluster to work? when i plug them in nothing happens when the car is started and the battery light goes away once started but oil light stays on.
Top
 Profile  
 
 
 Post subject: Re: EF-EL speedo cluster
Posted: Mon Nov 28, 2011 8:40 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

You need to add a Oil Sender Unit.

Please read:
documents.php?d=14

If you've grabbed a Fairmont cluster you'll need to add a resister for the instrument lights to work also.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: EF-EL speedo cluster
Posted: Mon Nov 28, 2011 9:28 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 552

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Brisbane
QLD, Australia

actually i was putting the GLI cluster in my XR6 with all the XR guages in the GLi cluster but when i start the car up the oil and battery dont appear to work for odd reason?
Top
 Profile  
 
 
 Post subject: Re: EF-EL speedo cluster
Posted: Mon Nov 28, 2011 11:03 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

Probably missing some components.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: EF-EL speedo cluster
Posted: Tue Nov 29, 2011 12:26 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Yeah, the GLI clusters are missing some surface mount components.
I take it to fit the voltmeter and oil pressure gauges you soldered in the gauge mounts ??

Better to get a fairmont or XR cct board. Change the mileage EPROM to suit - see the tech docs.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:38 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names