Fordmods Logo

EL Tickford Cluster 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: EL Tickford Cluster
Posted: Mon Jul 17, 2006 5:43 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 17

Joined: 12th Nov 2004

Ride: EL

Location: Newcastle
NSW, Australia

Ive not long ago fitted a EL XR dash to my el gli, and yesty whilst driving the dash finnally rolled over to 150,000 (put dash in at 147,ish) and the service spanner light never come on, i was wondering if this was a quirk with the XR dashes or if there was a way to enable and disable the spanner from showing up. Ive also added the low washer bottle and couldnt get it to illuminate on the odometer, but when i go into diag mode for the dash and go to the bottom where everythin is illuminated the spanner and the low washer both come on. could i just have a dodgey dash or am i missing somethin completely here, any help would be great..

Thanks
Top
 Profile  
 
 
Posted: Tue Jul 18, 2006 6:35 am 
Stock as a Rock
Offline

Age: 32

Posts: 115

Joined: 28th Sep 2005

Ride: BA Falcon XR6 Turbo

Location: Gold Coast
QLD, Australia

Hey mate,

i don't think you can disable the spanner. It turns on every 10,000k. The way to remove it is to disconnect the battery, otherwise just leave it showing, won't make any difference.

Have a good one

 

_________________

_Gianni_

Top
 Profile  
 
 
Posted: Tue Jul 18, 2006 10:40 am 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

i think you can hold the reset for ten secs or something. there was another post about it not long ago. getting the el done next week if you can wait till then

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
Posted: Tue Jul 18, 2006 10:42 am 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

the spanner light has been covered hundreds of times

to turn it off, just hold the trip meter reset button on the cluster in for ~10 seconds IIRC

 

_________________

Banned

Top
 Profile  
 
 
Posted: Tue Jul 18, 2006 11:18 am 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 10126

Joined: 5th Nov 2004

Gallery: 4 images

Ride: EF Gli Ghia, XP Fairmont

Location: Perth
WA, Australia

Phil (et al) Correct me if I'm wrong but isn't he asking why the spanner DID NOT come on after it rolled over 150,000 kms ... I don't see once where he is asking how to get rid of it !!!!!

 

_________________

Owning 1 of 67612 EF GLi Sedans made
FACT: "Chuck Norris owns the greatest Poker Face of all-time. It helped him win the 1983 World Series of Poker despite him holding just a Joker, a Get out of Jail Free Monopoly card, a 2 of clubs, 7 of spades and a green #4 card from the game Uno."

Top
 Profile  
 
 
Posted: Tue Jul 18, 2006 3:21 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4323

Joined: 17th Jan 2006

Ride: Soarer 2.5GT-T

Location: Cranbourne
VIC, Australia

people need to read before they post :p.
is there a seperate light there that lights up the spanner? ... otherwise i dunno lol.
My XR clocked 150 when i had it, and the spanner came on.
Top
 Profile  
 
 
Posted: Tue Jul 18, 2006 6:11 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 17

Joined: 12th Nov 2004

Ride: EL

Location: Newcastle
NSW, Australia

well ive checked all the globes, plus when put into diag mode it illumates all the icons on the odometer so it should be working, its got me stuffed as to why it isnt showing the spanner or the low washer bottle, ive even earthed the pin from the cluster straight out and it didnt bring the low washer bottle up,, maybe its just a dodgey cluster from ford, but i would like to get to the bottom of it...

thanks
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: lucasj95 and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 5:43 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names