Fordmods Logo

FORD EF XR6 dash cluster problems 


Page 1 of 1 [ 2 posts ] 

 Post subject: FORD EF XR6 dash cluster problems
Posted: Sat Feb 22, 2014 12:00 am 
Fordmods Newbie

Age: 21

Posts: 1

Joined: 21st Feb 2014

Ride: Ford Ef xr6

Location: Adelaide
SA, Australia

Hi guys I'm new here to the forum...

I own a 95 Ef xr6 5 speed manual
Recently I removed the dash cluster and replaced the stock facia with and aftermarket white one.
I unplugged the cluster from the car and took it inside and popped the needles off and replaced the facia, I clipped the needles back on in the "zero" position for everything.. I plugged the cluster in and started the car before I put my dash back together... The lights worked but the gauges weren't moving I popped the needles off a fee notches because I had the right down flat.
Once I popped them up a notch they all worked keep in mind I shut the car off first and unplugged the cluster... Once I plugged it all back in they all the needles did their thing... Now the headache
My tacho use to read 1000-800 (I have idling problems it fluctuates between)
Now it idles between 0-900 also my volt gauges use to read full 16 I believe now it's around 14 no biggie just letting you guys know... Now as far as fuel and temp I can't be certain on them because clearly fuel changes so I'm insure if it's reading correctly same goes with the temp... Oil pressure seems fine... I put it all together went for a drive my speedo was and still is reading wrong, I got home and unplugged the cluster after turning the car off, played with the needles for a bit and plugged it back in.... Punched it down the road still reading wrong so I came up with a stupid idea of turning the car off un plugging the cluster then starting the car and plugging the cluster in.. Hoping it would reset something went for a drive and I thought they where working but no their not it reads 45-7 when I'm doing around 60 odd so it's not like I can just shrug it off...
I played with it a few more times but it still reads wrong and I have no idea what to do I've been told to get the cluster re calibrated is going to cost me around $300 now keep in mind I live in Adelaide where everyone's just a pack of theiving pr*cks...
So can anyone help me with my cluster? And tips to getting them read correctly it's more then the speedo keep in kind it's basically everything I can't guarantee the fuels reading accurately same with temp... Thanks in advance guys :)
 Post subject: Re: FORD EF XR6 dash cluster problems
Posted: Sun Feb 23, 2014 5:31 pm 
Getting Side Ways

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia


The Speedo and Tacho sit on the bottom line, the other 4 gauges sit below. Have a look at another and set yours about the same. Next time take a Pic before you start, and I would also scratch a line in the white plastic housing of where the needle points. If you can get a normal one cheap you can swap the Speedo and Tacho, power off before you do anything. If not the Gauges it may be the electronics in the cluster. They do more than you may realize. I havnt taken the needles off my Falcon cluster often, but normally I twist and pull the needle off against the stop with my fingertips / nails.



Regards 96ELGli

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 4:16 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names