Fordmods Logo

Heater not working 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Heater not working
Posted: Mon Apr 04, 2011 8:36 pm 
Stock as a Rock
Offline

Age: 27

Posts: 150

Joined: 3rd Apr 2010

Gallery: 1 images

Ride: BA XR6 Turbo

Location: Caboolture south
QLD, Australia

Pretty much just the other morning bit cold, put the heater on, and nothing but fresh air, thought ill wait for the engine to warm up a bit more, and still no heat even when my engine was at normal temp.... air con works tho, it worked like a couple months ago or so when i last used it, never use it much tho. does anyone know what it could be?

 

_________________

BA XR6T Manual 220rw kw - 20' chromies, pedders ultra lows, hurricane 2.5' twin exhaust by Fat Pipes, PBR premium slotted brakes, leather pack, and soon more under the bonnet!

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Thu May 05, 2011 4:25 pm 
Oompa Loompa
Offline
User avatar

Age: 27

Posts: 31

Joined: 5th May 2011

Gallery: 1 images

Ride: 2004 BA Futura

Location: St Andrew's Beach
VIC, Australia

Yeah, I have the same problem in my BA: Without the A/C it's just cold, with the A/C it's only colder. My mechanic had a look, and said that the heater core is still heating up fine, but the plastic piece which moves to divide hot/cold air coming through the vents doesn't move when you swivel the heat controls. He said to take it to Ford, they may have to take out the console in order to repair it, but the piece itself ought to be dirt cheap.

As I bought my car in December, I had no use for a heater until about two weeks ago, I didn't notice the problem until then!!

 

_________________

2001 AUII Futura - Written off
2004 BA Futura - Mods only beginning...

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Mon May 09, 2011 7:20 am 
Stock as a Rock
Offline

Age: 27

Posts: 150

Joined: 3rd Apr 2010

Gallery: 1 images

Ride: BA XR6 Turbo

Location: Caboolture south
QLD, Australia

Yer, thats like the same as me, i really need the heater now.
but wierd thing was, my airbag light was coming on aswell, and supposedly theres some loose connections underneath the passenger seats in ba's. Since my seats have airbags in them, i took a look under wedged the connection in a bit tighter, and that fix the airbag light coming on and also fixed the heater????? so wierd, so try that if you also have airbag light on too.

 

_________________

BA XR6T Manual 220rw kw - 20' chromies, pedders ultra lows, hurricane 2.5' twin exhaust by Fat Pipes, PBR premium slotted brakes, leather pack, and soon more under the bonnet!

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Mon May 09, 2011 8:13 am 
Getting Side Ways
Offline

Age: 29

Posts: 2563

Joined: 19th Feb 2007

Gallery: 21 images

Ride: 98 EL Futura

Power: 199 rwkw

Location: Lilydale
VIC, Australia

iv got the same thing, its getting bloody cold in the mornings now. I need to it fixed.

 

_________________

EL Futura: CVE head, Wolf V500, ICE Ignition and Coil, 36lb injectors, Walbro 255lb, Paci comps, 3" exhaust, T5, Harrop Truetrac with 3.9s. Now with 198.9rwkw, (~185rwkw and 13.80 @99.1mph) with more power to come

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Tue May 10, 2011 11:25 am 
Oompa Loompa
Offline
User avatar

Age: 27

Posts: 31

Joined: 5th May 2011

Gallery: 1 images

Ride: 2004 BA Futura

Location: St Andrew's Beach
VIC, Australia

No, I don't have any airbag problem, but that's interesting.

Went to Ford - even if the heater flap is the only thing wrong (a $40 piece), it's $520 just for the job. Blankets are cheaper.

 

_________________

2001 AUII Futura - Written off
2004 BA Futura - Mods only beginning...

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Tue May 10, 2011 11:42 am 
Getting Side Ways
Offline
User avatar

Age: 53

Posts: 1072

Joined: 6th Jul 2006

Gallery: 13 images

Ride: BA Falcon

Power: 106 rwkw

Location: Craigmore
SA, Australia

Its a $500 job because the whole dash has to come out.....

Sounds like someones going to have a fun weekend...........

 

_________________

2003 BA Falcon Egas Taxi Pack - XR Replica
Tpak MKII Build Thread

1984 ZL Fairlane
The Project

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Thu May 12, 2011 4:43 pm 
Oompa Loompa
Offline
User avatar

Age: 27

Posts: 31

Joined: 5th May 2011

Gallery: 1 images

Ride: 2004 BA Futura

Location: St Andrew's Beach
VIC, Australia

At this point, my girlfriend is refusing to ride in my car. I'm gonna have to get this fixed...

Does anyone know any mechanics on the Peninsula who know Fords well, without the Dealership prices??

 

_________________

2001 AUII Futura - Written off
2004 BA Futura - Mods only beginning...

Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Fri May 13, 2011 1:55 am 
Parts Gopher
Offline

Age: 33

Posts: 77

Joined: 12th May 2011

Ride: Ford Falcon EL

Location: Perth
WA, Australia

Hi mate,

It will always cost you quite a bit on labour as it is a time consuming job.

If I were you I would do it myself (if your halfway handy, that is) I did it on a EL Falcon recently. Is a common Falcon issue. Don't know why they break though, guess they become brittle or its one of those things Ford designed to break and make you pay... :twisted:

It's a hell of a job but nothing too complicated. You will need to bolt the whole dash out. It will cost you only the 40 odd bucks for the flap, but a day of labour if you take your time. Get a set of torx allen keys or sockets and you should be sweet. Once you get to the box the job is fairly easy and straightforward, only a b**ch to get to...

Good luck if you are going to try, sure you'll be allright though.
Top
 Profile  
 
 
 Post subject: Re: Heater not working
Posted: Fri May 13, 2011 11:00 am 
Oompa Loompa
Offline
User avatar

Age: 27

Posts: 31

Joined: 5th May 2011

Gallery: 1 images

Ride: 2004 BA Futura

Location: St Andrew's Beach
VIC, Australia

yeah, I don't reckon I'd be competent (or confident) enough to do it myself... might just ask my mechanic.

 

_________________

2001 AUII Futura - Written off
2004 BA Futura - Mods only beginning...

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:21 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names