Fordmods Logo

Installed new stereo in EB2 now dash/park lights don't work! 


Page 1 of 1 [ 5 posts ] 

 Post subject: Installed new stereo in EB2 now dash/park lights don't work!
Posted: Sat Jul 16, 2005 11:56 pm 
Fordmods Newbie

Posts: 1

Joined: 16th Jul 2005

Ride: EB2

Location: East Melbourne
VIC, Australia

I've just installed a new stereo in my EB2 station wagon. Now the stereo works fine but the dash lights and park lights don't work. With the wiring there was one wire left over when converting the stock wires to the new stereo, a brown wire. I now know this has something to do with the parkers. Does anyone know where I can hook this wire up to to get the parkers/dash lights working again?

Posted: Sun Jul 17, 2005 2:13 am 
Technical Contributor

Age: 30

Posts: 6047

Joined: 12th Nov 2004

Ride: Ford Ef Futura

Location: Perth
WA, Australia

Check fuses. Thats the first thing I learnt, always check fuses.

Other then that, pull out stereo, grab the wiring diagram from your headunit boxing pacakage and find it out through taht.

What headunit you got?
Posted: Sun Jul 17, 2005 3:28 am 
Technical Contributor
User avatar

Age: 52

Posts: 5472

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Recheck your wiring just to confirm correct connection, here's a list of the applicable wires not including speaker wires:
Black: Earth
Green/Yellow: From Courtesy light power.
Grey/Yellow: Goes to power windows, so likely to not be needed.
Brown: Goes to Park Lamps.
Red/Blue: From Central Controller.

Sounds like the Park Lamp Fuse (15A) is blown, check to confirm it's okay, if that's the case, check for 12v from that brown wire when parkers are switched on.
I'd say courtesy light power is used for stereo operation, lighting is usually via the red/blue & brown wires - so I'd say the radio has no lighting currently until that brown wire is connected. The brown wire comes from the parkers, so doesn't need to be connected for the parkers to work.



96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Posted: Sun Jul 17, 2005 11:49 am 
Getting Side Ways
User avatar

Age: 37

Posts: 1434

Joined: 5th Nov 2004

Gallery: 15 images


Location: Sunshine Coast QLD
QLD, Australia

Sounds like a bad earth, When installing car stereos, I always add new wires for the headunit from the battery, and don't use the standard ford ones. (stocko head unit comes from) .

But yeah, as above, sounds like a fuse has gone, there is one fuse that controls the dash/parker lights.
Posted: Sun Jul 17, 2005 7:42 pm 
Getting Side Ways

Age: 33

Posts: 452

Joined: 15th Feb 2005

Location: Sydney
NSW, Australia

You might of grounded it with the wrong ground as i did this once. One fo the ground wires runs through the parkers, so find ur ground and ground it another way. ohhh and also check ur fuses as u probably blew 1.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 10:35 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names