Fordmods Logo

Lights out? - Cluster 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Lights out? - Cluster
Posted: Mon Nov 22, 2004 9:28 am 
Smokin em up
Offline
User avatar

Age: 34

Posts: 241

Joined: 5th Nov 2004

Ride: R33 GTS-T

Location: Melbourne
VIC, Australia

The left hand side of my cluster does not light up at all, even the LCD display globes are not on. Is this the cluster? a fuse? the connector?

The right hand side is fine.

 

_________________

Hope is the first step on the road to disappointment.

Top
 Profile  
 
 
Posted: Mon Nov 22, 2004 10:39 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 654

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AU XR6

Location: Mulgrave
VIC, Australia

most likely one of the globes are blown, has this been since you purchased the car or has it only just happend.

If it is a globe you can buy them from ford but they only come in the holder you cant just buy the globe.

The globes work in series (i think it is) so if one blows the rest wont be provided with power for that track, the cluster is easy to take out there ar 2 lugs in the top of the cluster just pop them out undo the 2 screws. Then push the bottom of the cluster in and you can pull the cluster out you may need a screw driver to help pull it out through one of the holes in the top.

 

_________________

1992 EBII 5L Fairmont Ghia Wagon
1999 XR6 6 Speed manual
Build Thread

Top
 Profile  
 
 
Posted: Mon Nov 22, 2004 4:18 pm 
Smokin em up
Offline
User avatar

Age: 34

Posts: 241

Joined: 5th Nov 2004

Ride: R33 GTS-T

Location: Melbourne
VIC, Australia

Ahh sweet easy fix then, time to go for LEDs

 

_________________

Hope is the first step on the road to disappointment.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:46 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names