Fordmods Logo

My lights have a mind of their own!!! 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: My lights have a mind of their own!!!
Posted: Tue Mar 28, 2006 11:14 pm 
Oompa Loompa
Offline

Age: 32

Posts: 31

Joined: 6th Nov 2004

Gallery: 1 images

Ride: EF Falcon GLI

Location: Caboolture
QLD, Australia

I have a EF falcon and recently my brake light switch went on me. The problem was not this. After i bought a new one and fitted it using the technical doco, when i depress my brakes, its great, brake lights come on.
However, my parkers also come on aswell as my dash lights. (Thats when my lights are turned off). When the lights are turned on, all my back lights are on, including brakes, rear spoiler and my number plate light.

I have done some reading through the forums and thought i might have bumped the earth wire or something underneath the footwell. i had a look and i'm pretty sure i found that earth. its brown and bolted to a bit of metal. it seemed to be fine. now im wouldnt have a clue how to fix it and auto elecs cost a S*#! load.

Can any one help before my wallet gets emptied !
Top
 Profile  
 
 
Posted: Tue Mar 28, 2006 11:31 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 1640

Joined: 16th Jun 2005

Gallery: 11 images

Ride: EF Falcon

Location: Driver's Seat
VIC, Australia

Well I'm no Image so dont quote me on this... but maybe you bought a wrong break switch?? :?

 

_________________

-------- Falcs --------
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

Top
 Profile  
 
 
Posted: Tue Mar 28, 2006 11:43 pm 
Oompa Loompa
Offline

Age: 32

Posts: 31

Joined: 6th Nov 2004

Gallery: 1 images

Ride: EF Falcon GLI

Location: Caboolture
QLD, Australia

I got it from a wreckers called JUST FORD. Hopefully they knew what i was talking about. the guy there said it a very common problem and by all the topics on brake light switches in this forum.........
Top
 Profile  
 
 
Posted: Thu Mar 30, 2006 12:17 am 
Oompa Loompa
Offline

Age: 32

Posts: 31

Joined: 6th Nov 2004

Gallery: 1 images

Ride: EF Falcon GLI

Location: Caboolture
QLD, Australia

Any suggestions ???????
Top
 Profile  
 
 
Posted: Thu Mar 30, 2006 12:17 am 
Oompa Loompa
Offline

Age: 32

Posts: 31

Joined: 6th Nov 2004

Gallery: 1 images

Ride: EF Falcon GLI

Location: Caboolture
QLD, Australia

Any suggestions ???????
Top
 Profile  
 
 
Posted: Thu Mar 30, 2006 10:40 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Undo the stop/taillight bulb holders, remove the bulbs - you should have dual filament bulbs in both left and right. I'm suspecting you have a single fitted in at least one side, which can short both park/stop terminals, causing what you're experiencing.
If you operate your brake pedal with ign on, with both bulbs removed, and your inst lights don't come on with the pedal, then that will be your culprit.
Check the bulb holders as well to see if the terminals aren't shorting of their own accord.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Thu Mar 30, 2006 11:07 am 
Oompa Loompa
Offline

Age: 32

Posts: 31

Joined: 6th Nov 2004

Gallery: 1 images

Ride: EF Falcon GLI

Location: Caboolture
QLD, Australia

Thanks your a legend that was it !
Top
 Profile  
 
 
Posted: Thu Mar 30, 2006 11:22 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

No probs.... :P

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Fri May 16, 2008 3:31 pm 
Fordmods Newbie
Offline

Posts: 1

Joined: 16th May 2008

Location: melbourne
VIC, Australia

Thanks 'snap0964'
I had the same issue as 'TrainerJ' - 3 years of braking issues and countless dollars spent when all i needed was the right bulb!

For anyone else with the same issues -
Mines a '96 falcon futura, got three bulbs on the back left and three on the right. the outside ones were single filament orange indicator bulbs, the 'middle ones' needed to be dual filament (i had only one side with dual), and the inner bulbs i left as single filament also. all good now. in the past when braking the back right lights would flash briefly then go off, as would the centre bulb. only one light on the back left would stay on (dual filament i now realise).

i won't be wasting any more money at service centres and listening to their ever changing excuses about whats wrong with my wheels when they couldn't even check the darn globes.

thanks forum!
Top
 Profile  
 
 
Posted: Fri May 16, 2008 3:41 pm 
Getting Side Ways
Offline

Age: 29

Posts: 638

Joined: 16th Feb 2005

Ride: EA Turbo

Location: Melbourne
VIC, Australia

I've got the same problem with my mums AU2, now I know how to fix it, also had the same problem with my old EA....thought it had something to do with the towbar wiring but I guess it was only the wrong globes :S

 

_________________

1988 EA S-Pack|MPI|LSD|AIT turbo manifold|Garrett GT3540|3" Exhaust turbo back|Resprayed|microtech LT8s|60lb Injectors|Bosch 044 with surge tank|3000 RPM stall|Ported AU head|Wade turbo cam|Crow double valve springs|1.3mm MLS headgasket|C4 conversion|Built bottom end|10.6@125MPHi

Top
 Profile  
 
 
Posted: Fri May 16, 2008 11:10 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3531

Joined: 5th Nov 2004

Gallery: 25 images

Ride: 93 Maverick LWB/S2 LWB Delica

Power: 75 rwkw

Location: uoʇǝlƃuıs lʍoq ʇsnp
NSW, Australia

Another thing to add is sometimes a brake or tail filament can break and short across to each other, doing the same thing.

 

_________________

93 Ford Maverick LWB automatic petrol guzzler (gets stuck where Deli doesn't, big pumpkins :evil:)
97 S2 Mitsubishi Delica LWB (off the road getting v8 transplant) http://tmacmechanical.com.au/

Top
 Profile  
 
 
Posted: Mon May 19, 2008 7:04 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1132

Joined: 11th Jun 2006

Gallery: 1 images

Ride: ef fairmont,

Location: brisbane
QLD, Australia

this could be my issue have posted in 6cyl egine section but mine seems little worse than this one

http://www.fordmods.com/forums/wierd-el ... 64956.html


please read and help :cry:

 

_________________

95 ef montfor sale pm for info, 88 hilux mud truck

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: Spinb and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:19 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names