Fordmods Logo

Problems with lights 


Page 1 of 1 [ 2 posts ] 

 Post subject: Problems with lights
Posted: Sun Jun 20, 2010 6:47 pm 
Fordmods Newbie

Posts: 6

Joined: 20th Jun 2010

Ride: 10 FG XR6T

Location: Newcastle
NSW, Australia

Hello all

Just got home and discovered a problem with the car. Parking lights, cluster/ ICC lighting and tail lights aren't coming on. Just wanting to confirm that there's no fuse or relay which deals specifically with the three light circuits. High and low beam works fine. I've checked each of the tail light, ICC, and Cluster fuses and they're all fine.

I'm thinking its the indicator/ headlight switch in the steering column, anyone know what one would be worth intalled?

 Post subject: Re: Problems with lights
Posted: Sun Jun 20, 2010 7:23 pm 
User avatar

Age: 39

Posts: 2265

Joined: 6th Oct 2005

Ride: 93 EBII fairmont & 2004 BA Turbo

Location: Western Sydney
NSW, Australia

its possible the switch is faulty. Very expensive to fix ive heard. But ive only heard this from a Ford dealer.



93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 7:22 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names