Fordmods Logo

Trip computer issues???? 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Trip computer issues????
Posted: Sat Nov 17, 2007 1:57 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 2

Joined: 17th Nov 2007

Ride: EL Fairmont wagon

Location: Renmark
SA, Australia

Can anybody help me with my faulty trip computer in my EL Fairmont wagon.
The problem is that the LCD is very, very dim. Is there an LED or light globe behind the unit which illuminates the reading or am I likely to have to replace the whole unit? Also not having done it before how do I get into the trip computer to remove or check the situation? Step by step process would be great. Thanks for the assistance.
Top
 Profile  
 
 
Posted: Sat Nov 17, 2007 2:19 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

The unit is lit by a T5 globe, and another T5 lights the controls and wording. Just pick up a couple from local parts place, drop off the dash fachia unscrew the trip comp and take out the globe holders, same as dash globes and pull out the bulbs, in with new ones and your away. If the bulb holders are blue you won't be able to pull out the globes, if this is the case you will need to buy complete units, Auto One carry them. Hope this is of some help.
Top
 Profile  
 
 
Posted: Sat Nov 17, 2007 2:27 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 2

Joined: 17th Nov 2007

Ride: EL Fairmont wagon

Location: Renmark
SA, Australia

Thanks PaulC. What is involved in taking the dash apart? I have never done this before. I believe that there are about 8 screws to remove (Somewhere). Is there a link that you know of that may help me. Thanks
Top
 Profile  
 
 
Posted: Sat Nov 17, 2007 3:17 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Try this Tech doc, tells you how to pull out the dash facia

http://www.fordmods.com/forums/documents.php?doc=1
Top
 Profile  
 
 
Posted: Sat Nov 24, 2007 2:45 am 
Parts Gopher
Offline

Age: 54

Posts: 79

Joined: 28th May 2007

Gallery: 1 images

Location: melbourne/ brunswick
VIC, Australia

all done?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:11 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names