Fordmods Logo

EB II Fairmont major LPG issues 


Page 1 of 1 [ 1 post ] 

 Post subject: EB II Fairmont major LPG issues
Posted: Mon Dec 05, 2011 4:51 am 
Getting Side Ways

Posts: 593

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

Hey guys, I've got a problem with my EB II and I can't figure out what's causing it.

Sometimes when cruising/driving the car will drop revs to around 1000RPM. It won't rev any higher regardless of how far down the accelerator is. If I let it idle in D or N it runs extremely chuggy/lumpy but surprisingly doesn't cut out. It started doing this a few weeks ago and seems to be happening more often, it fixes itself after 30 seconds or so sometimes and other times I just switch the key on and off and eventually it'll kick back in. It does it up the hill in mainstreet a fair bit and I always have to limp over it at 30km or so until it decides to kick back in, which is getting pretty frustrating haha.

Similiar things happen after I floor it, and when I start it (warm or cold). It feels like a gas issue to me.

Any help would be greatly aprecciated!

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 8:59 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names