Fordmods Logo

ef gas stuff (long post, sorry) 


Page 1 of 1 [ 2 posts ] 

 Post subject: ef gas stuff (long post, sorry)
Posted: Sun Aug 05, 2007 7:05 pm 
Getting Side Ways

Posts: 938

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

G'day thrillseekers. just a bit of info that might help someone.

I was (am) having lots of trouble with an EF Tickford LPG system. It would almost stall on idle, and hunted badly on idle, and had a bad "dashpot" effect. I.E.: it took a while to get back down to idle from a rev up. But overall, it ran well.

Anyway, I have traced andf ixed most of the probs:

1) the inlet tract from the point where the two tracts go into "one", that great big black thing on the top of the motor, well it was split completely down one side, on the seam, so it couldn't be seen readily. I have silasticed it up. :D

2) The pipe that goes from the airbox to the converter was also split, only a little bit, and I taped that up with trusty "go-faster" tape. (BTW Ford want 65 bloody dollars for this :shock: :shock: )

3) on the underside of the throttle body is a take-off, which I think is originaly used for the rocker breather. Tickford change this takeoff point to near the gas ring. They also cover the original take-off point with a rubber cap. This cap had deteriorated a LOT, and I think was also part of the problem. Fixed that.

4) By using my daughters toy stethescope, I have found that the rubbers on the injectors are leaking, as I can hear the air going in. I intend to replace them.

The upshot of all this is that the car now idles, although not altogether properly yet (injectors?) it has lost the dashpot effect (lean running?) and no longer tries to stall at idle. I have also put a new set of plugs in

I hope this helps someone. It seems the system is very sensitive to vacuum leaks
Posted: Sun Aug 05, 2007 9:11 pm 
Parts Gopher

Posts: 96

Joined: 4th Jun 2007

Location: Melbourne
VIC, Australia

i two have an ef with a tickford system an i have idil problems. When i get up in the morning an start it for the first time it stalls then i crank it again and it dosent stall and runs nice. But my idil is a problem when stopd it idils at 600 which it should be around 750 but when i adjust it, it just goes back after awhile.

Also wat are some ways of improving gas econonmy?



EF 96 5 speed, Wades Cam, Extractors, 2'5 Straight through exhaust, High flow injectors, Cold air intake, Adjustable Fuel Pressure Regulator, 17's lowered on SSL King Springs...

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 12:46 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names