Fordmods Logo

idling problem on lpg only el xr8 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: idling problem on lpg only el xr8
Posted: Tue Apr 29, 2008 11:47 pm 
Oompa Loompa
Offline

Age: 42

Posts: 27

Joined: 14th May 2007

Ride: el xr8

Location: quakers hill
NSW, Australia

hi all i have an idling problem on lpg only, doesnt happen all the time only now and then, system is a landi controller v2, only 8 mths old runs good, every now and then when i pull up, the idles drop right down and goes to stall and i can smell the gas like it might be getting to much or not enough, then i can turn engine off and restart and 90% of the time it will be ok, the car will run fine for ages and then all of a sudden it will do this, it done it today when i got home from work on my front yard, idles dropped and ran rough, i given up with the installer hes a joke so im looking for a place that might be able to help me,im in quakers hill nsw, the system came from apollo gas but was not installed by them, the car idles great on petrol and never has a problem, awhile ago it done this and we replaced throttle body and idle control units, also when i do 60k plus on a trip at the same revs it seems to jerk back and forward only on gas not petrol but not all the time, like its also starving for gas, im starting to believe maybe a faulty part or the installer didnt tune computer properly, so if anyone with knowledge can help please pm me regards chris
Top
 Profile  
 
 
Posted: Wed Apr 30, 2008 7:17 am 
Getting Side Ways
Offline

Age: 48

Posts: 1061

Joined: 7th Sep 2007

Gallery: 3 images

Ride: BF3 Egas wag SY AWD Terry Ghia

Location: Brookfield
VIC, Australia

you need to adjust the idle mixture

 

_________________

BF3 Egas XT Wagon
SY Territory Ghia AWD 6spA :))

Top
 Profile  
 
 
 Post subject: lpg
Posted: Wed Apr 30, 2008 7:24 am 
Oompa Loompa
Offline

Age: 42

Posts: 27

Joined: 14th May 2007

Ride: el xr8

Location: quakers hill
NSW, Australia

hi there mixture adjustment is controlled by the lpg ecu, could it be a faulty stepper regards
Top
 Profile  
 
 
Posted: Sat May 03, 2008 11:55 pm 
Fordmods Newbie
Offline

Posts: 10

Joined: 3rd May 2007

Location: Adelaide
SA, Australia

Hey dcjacko, trial and error,if all didnt work, possible your converter need to be replace.and you know the difference.
Top
 Profile  
 
 
 Post subject: LPG IDLE
Posted: Sun May 04, 2008 2:03 am 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Also would pay to check coolant levels,flow and thermostat.
Top
 Profile  
 
 
Posted: Sun May 04, 2008 3:19 am 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

is the motor timing set for petrol or lpg?

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
Posted: Mon May 05, 2008 12:39 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 1093

Joined: 29th Nov 2004

Gallery: 15 images

Ride: BA Ford Fairlane V8

Location: Lower Hunter Valley
NSW, Australia

Also the O2 sensors could be on the way out. These are really important for your closed loop controller.

 

_________________

Interested in a fair go for the Hunter-New England area of NSW?

Top
 Profile  
 
 
 Post subject: still hass problem
Posted: Thu Jun 12, 2008 12:12 am 
Oompa Loompa
Offline

Age: 42

Posts: 27

Joined: 14th May 2007

Ride: el xr8

Location: quakers hill
NSW, Australia

hi all i have replaced nearly everything, has problem on idle in drive only when on lpg, idles drop starts hunting smells like gas,switch to petrol then back then ok , or drive for a min or 2 then will be ok,90% of the time no problem it has got me stumped unsure of the cause system only 9mths old but mechanic is a bodgy jerk, its not injected but computerised maybe he hasnt set properly not sure????
Top
 Profile  
 
 
 Post subject: idling problems
Posted: Sun Jun 15, 2008 10:23 pm 
Getting Side Ways
Offline
User avatar

Posts: 708

Joined: 9th Nov 2004

Ride: Falcon

Location: Liverpool
NSW, Australia

take it back to the installer or have you ?? if not pop it round & I'll spend some time with you might be just a mixture adustment ??

Joe
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:35 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names