Fordmods Logo



Page 2 of 2 [ 18 posts ] Go to page Previous  1, 2

Posted: Mon Aug 27, 2007 10:58 am 
Getting Side Ways
User avatar

Posts: 659

Joined: 14th Apr 2006

Ride: EF Fairmont Sedan

Power: 180 rwkw

Location: Ferntree Gully
VIC, Australia

Xbcoupe wrote:
just a question mate how old were they and do you know what caused the pitting? ive had a set for about 3 1/2 years and i havent noticed any pitting yet , and i want to keep it that way 8-)

They were/are about that old and the only reason for the pitting is that the previous owner didnt clean the brake dust off. Then the Brake Dust gets wet and eats into the chrome.

Obviouslly the previous owner cleaned the spokes and the dish which are the easy bits but not the hard bits in-between the spokes and at the bottom of the spokes.

When I got them it took me 2 hours on each wheel to clean them.

The bits that were kept clean are still in mint condition and obviouslly he knew how to drive as they didnt have any gutter damage.

So if you keep them clean you wont get pitting :)



PROEF 13.46 @ 105.78mph - 1994 Ford Fairmont EF NA 6cyl Man 3.9 diff Sedan
Stock Fuel Pump, 29lb Injectors, JMM Street Series Headers, 2.5" Exhaust, 205rwkw

Posted: Mon Aug 27, 2007 11:03 am 
Getting Side Ways
User avatar

Age: 40

Posts: 516

Joined: 7th Mar 2005

Gallery: 4 images

Ride: -74 XB Coupe

Location: raymond Terrace
NSW, Australia

ok cheers mate 8-)
thats what i was thinkin too bloody brake dust , i keep mine pretty clean so it should be ok



2006 BF MkII FPV F6 TYPHOON 6sp Manual
Nizpro Injectors, Nizpro Polished Stage 2+ cooler,
X-force 4"dump pipe & 2 1/2" Dual Exhaust, Walbro fuel pump
Tunning by BlackTrack Performance.
507.1 RwHp

Posted: Mon Aug 27, 2007 11:28 am 
Getting Side Ways
User avatar

Posts: 1863

Joined: 30th Apr 2006

Location: Melbourne
VIC, Australia

It's funny, I've seen quite a few chromies do this from not being cleaned often/brake dust, however I had a set of chromies on one of my previous cars, paddock bashed it, drove down dirt/mud roads every day, and didn't wash the car for a year, and after a good scrub they came up good as new! Guess I was lucky.
Display posts from previous:
Sort by  
 Page 2 of 2  [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Facebook [Bot] and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 9:03 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names