Fordmods Logo

Blower not boosting 

 

Page 1 of 3 [ 39 posts ] Go to page 1, 2, 3  Next

 
 Post subject: Blower not boosting
Posted: Fri Dec 07, 2007 11:58 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

I've got a CAPA 9psi Powerdyne kit but with a 6psi pulley currently (got the 9psi kit as I wanted the watercooling, injectors, FMU and all the other bits and peices fitted now for later when I fit the 9psi pulley) all fitted to my EF I6.

Now I've only driven the vehicle 70kms since and have been babying it around - the instructions said no boost for the first 150kms keeping the revs under 3,600rpm.

I got rid of the black plastic Bosch BOV and have instead fitted a Turbosmart Type III with the supercharger spring. Now if I rev the vehicle and let go, it's lets out a woosh so the blower is obviously putting pressure in.

But just before coming home I got a bit overly keen and mashed the loud pedal and the vehicle didn't impress at all - the stock EBII Fairmont I've been driving lately has more balls!!! The vacum/boost gauge didn't show any boost, and based on the performance I believe it's correct.

Now as I said the BOV is opening and releasing pressure, so that leads me to believe the blower is working, so somethings stoping it from actually forcing the air into the engine? Leaking intake pipe? Any other ideas on what to check?

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 12:17 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

im going to be a bit "captain obvious" here.. but do you have an intercooler? and if so double check the silicon hoses attached to it? leading in and out....

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 12:18 pm 
Getting Side Ways
Offline

Age: 38

Posts: 1319

Joined: 5th Nov 2004

Ride: 66 Coupe

Location: Perth
WA, Australia

Did you block the breather hose that goes to the back of the rocker cover?
Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 12:39 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

66 coupe wrote:
Did you block the breather hose that goes to the back of the rocker cover?


No, that's fitted with a mini breather filter - so it's no longer hooked into the air intake.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 12:40 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

fordfreak ef wrote:
im going to be a bit "captain obvious" here.. but do you have an intercooler? and if so double check the silicon hoses attached to it? leading in and out....


No intercooler - only running 6 psi at the moment, plan is to fit the 9 psi pulley and an intercooler sometime in the next few months.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 1:27 pm 
Getting Side Ways
Offline

Age: 34

Posts: 3406

Joined: 7th Feb 2005

Ride: AU2 Ute

Location: melbourne
VIC, Australia

I bet slipping belt or a big leak or both.
Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 1:48 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

how far did u rev it?

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 4:42 pm 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

EFFalcon wrote:
how far did u rev it?

Thats what I was thinking, the way centrifugals work, and especially on that amount of boost, you are gonna get sweet f**k all down low.
The less boost you run, the more it only comes on later in the rev range.

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 5:54 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

EFFalcon wrote:
how far did u rev it?


Just past 4,000 rpm. Surely by then it should able to produce at least 1 psi? It's also worrying that at 4,000rpm it only pulls as hard as my sisters Hyundai!

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 6:09 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 7029

Joined: 18th Apr 2005

Location: Hobart
TAS, Australia

Reinstall the bosch BOV & work from there. maybe its a dummy turbosmart that woosh every time it makes 1 PSI. LOL

Or you f**k up the gears before it was run-in probably!?!?

 

_________________

Mind f**k!!! it works on feeble minded ignorant sheeples... there's plenty of em on this site... some are very intelligent but by god they are so thick!!!

Pakrat wrote:
You can buy them seppertly

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 6:22 pm 
Smokin em up
Offline

Posts: 276

Joined: 2nd Aug 2005

Location: brisbane
QLD, Australia

check the vacuum line to the top of the blow off valve hasnt popped off or something like that. cos that actually causes the activation of the blow off valve
Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 10:18 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 7029

Joined: 18th Apr 2005

Location: Hobart
TAS, Australia

Trikee wrote:
check the vacuum line to the top of the blow off valve hasnt popped off or something like that. cos that actually causes the activation of the blow off valve
:idea: hmmm!

 

_________________

Mind f**k!!! it works on feeble minded ignorant sheeples... there's plenty of em on this site... some are very intelligent but by god they are so thick!!!

Pakrat wrote:
You can buy them seppertly

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 11:27 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

Trikee wrote:
check the vacuum line to the top of the blow off valve hasnt popped off or something like that. cos that actually causes the activation of the blow off valve


It's tight like a tiger - it's got fuel injection hose clamp on it too.
It was actually suggested to me that I might have the BOV on too soft a setting - I've adjusted it to it's hardest and need to take a test drive now.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 11:29 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

Slick wrote:
Reinstall the bosch BOV & work from there. maybe its a dummy turbosmart that woosh every time it makes 1 PSI. LOL


No can do, it would mean that I'd have to hack up my intake piping to fit the Bosch BOV.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Dec 07, 2007 11:47 pm 
Getting Side Ways
Offline

Posts: 539

Joined: 30th Nov 2004

Location: Melbourne
VIC, Australia

What spark plugs are you using ?

you could be getting spark blowout....a mate got the capa charger kit on a commo - took it to a couple of tuners all said belt slippage but wasn't the cause, some guy mentioned that at a certain Boost level the spark weakens, and will feel like the belt is slipping. my mate got annoyed changed to a MSD ignition and after market ECU and fixed the problem. not sure if it was the spark or the ecu but could be worth a shot.

Reduce your plug gap bout 50% and see what happens.

Also do you have a boost gauge ? if so what is it reading ?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 3  [ 39 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 11:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names