Fordmods Logo

losing boost? 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: losing boost?
Posted: Fri Oct 26, 2007 12:51 pm 
Oompa Loompa
Offline

Posts: 24

Joined: 28th Aug 2007

Gallery: 1 images

Location: Castlemaine
VIC, Australia

got a Eb fairmont turbo and seem to be losing 3-4 psi? can feel the lose of power, i have checked my piping and i have no leaks, i noticed there is a little bit of flex with the waste gate and was wondering if i made a better bracket could that be the problem?
Top
 Profile  
 
 
Posted: Fri Oct 26, 2007 7:13 pm 
Stock as a Rock
Offline

Posts: 170

Joined: 10th Nov 2005

Location: Canberra
ACT, Australia

intake tract leak, exhaust leak, cracked manifold, leaking BOV, etc etc

many sources

wastegate loose? sounds odd

 

_________________

http://www.TURBO351.com

2V 351T, 732rwhp@15psi on LPG.

Top
 Profile  
 
 
Posted: Fri Oct 26, 2007 7:42 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1204

Joined: 9th Nov 2004

Gallery: 11 images

Ride: EL Fairmont Ghia V8 Turbo

Power: 303 rwkw

Location: Melbourne
VIC, Australia

Get a boost gauge onto it

 

_________________

EL Fairmont Ghia V8 Turbo 303rwkw
Image

Top
 Profile  
 
 
Posted: Mon Oct 29, 2007 12:00 am 
Getting Side Ways
Offline
User avatar

Posts: 1863

Joined: 30th Apr 2006

Location: Melbourne
VIC, Australia

Had the exact same thing recently, and was a rooted cat.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 5:52 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names