Fordmods Logo

power loss above 3000rpm 

 

Page 1 of 2 [ 21 posts ] Go to page 1, 2  Next

 
 Post subject: power loss above 3000rpm
Posted: Mon Jan 29, 2007 9:34 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

hi, finally got a turbo setup on the car.

T3 turb A/r .63
chiptorque chip
AU injectors
AU head
de comp
beefed tranny
10psi boost
Bosch 044 pump
iridium plugs

my car was working fine till later on today, its ok on first then when on second its like it strugling to go up the rpm's, whats the problem? not engought Fuel? Plugs

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 9:43 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4849

Joined: 19th Feb 2005

Gallery: 1 images

Ride: BA Falcon Suzy Across

Power: 178 rwkw

Location: melbourne
VIC, Australia

is 10 psi alright to use on stock pistons?

 

_________________

178.3 rwkw
15.1@96 mph
Now with 3.9 shrooms

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 9:50 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

smiley235 wrote:
is 10 psi alright to use on stock pistons?


lol yes 10psi is no waries for them.


i would say u are running out of fuel

those au injectors a going to be good for f**k all, unless u stick 60+psi of fuel pressure into them

get a a/f meter

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 9:53 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

fritzz wrote:
smiley235 wrote:
is 10 psi alright to use on stock pistons?


lol yes 10psi is no waries for them.


i would say u are running out of fuel?

get a a/f meter




THE CAR WAS WORKING FINE TILL TODAY IT WORKS FINE ON FIRST BUT SECOND AND THIRD IT STRUGGLES?

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 9:57 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

t3 .63 to small, unless u don't want to rev it past 4000rpm.

also iridium plugs didn't last long in my car.
just stick a set of el xr6 ngk plugs(ZGR6B-11) and gap them to .9 or 1mm.

y did u choose a au head??

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:00 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

HiBoost wrote:
fritzz wrote:
smiley235 wrote:
is 10 psi alright to use on stock pistons?


lol yes 10psi is no waries for them.


i would say u are running out of fuel?

get a a/f meter




THE CAR WAS WORKING FINE TILL TODAY IT WORKS FINE ON FIRST BUT SECOND AND THIRD IT STRUGGLES?


ok no need to go in capitals, has your tank got less than 1/4 of fuel???

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:01 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

fritzz wrote:
t3 .63 to small, unless u don't want to rev it past 4000rpm.

also iridium plugs didn't last long in my car.
just stick a set of el xr6 ngk plugs(ZGR6B-11) and gap them to .9 or 1mm.

y did u choose a au head??



au has bigger exhaust valves, also the plugs are new just about 1000km on it, the car was very good till today.

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:02 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

it has half a tank of fuel.

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:03 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4849

Joined: 19th Feb 2005

Gallery: 1 images

Ride: BA Falcon Suzy Across

Power: 178 rwkw

Location: melbourne
VIC, Australia

got a rising rate fuel regulator?

 

_________________

178.3 rwkw
15.1@96 mph
Now with 3.9 shrooms

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:06 pm 
Getting Side Ways
Offline

Age: 33

Posts: 868

Joined: 23rd Sep 2005

Ride: eb falcon

Location: kadina
SA, Australia

plug leads s.hit themselves??

 

_________________

EB 4L, 8.4:1, R154, GT4202r, 4in exhaust, Greenslade Engineering exhaust manifold, plenum chamber, 90mm throttle, Garrett W2A cooler, Surecam custom, autronic SM4, Bosch 120lb, Crane HI-6, LX-92, LM-1, Turbosmart Reg, 2x bosch 044, turbosmart 48 gate. 470kw+ @ 18PSI

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:06 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

smiley235 wrote:
got a rising rate fuel regulator?



like a said the car was fine till today nothing wrong with it, i was able to rev it all the way to 5500rpm with no proble, but for some reason it just s**t it self, could it be the oxy sensor?

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:06 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

HiBoost wrote:
it has half a tank of fuel.


fill it up and see if that fixes it, my car seem to not like being below 1/4 of a tank even thou i have the pump as low as posible.

how much fuel pressure are u running and what reg are u running?

check to see if the vac line hasent come of the reg

check vac line to map sensor.

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:13 pm 
Smokin em up
Offline

Age: 30

Posts: 236

Joined: 2nd Jun 2005

Location: melbourn
VIC, Australia

stock reg, and when the car is on half a tank its no prob like it is....

 

_________________

4LTR-JET: 9.1 @150mph!!

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:21 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

well i don't believe that stock injectors at stock pressure would eva supply enough fuel for 10 psi.

have u eva had it at 1/2 tank or below since that 044 has been in?

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
 
Posted: Mon Jan 29, 2007 10:25 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 975

Joined: 26th Nov 2004

Ride: el falcon

Power: 608 rwkw

Location: Waroona
WA, Australia

as ebs_4l said, the ignition lead are very lickly to do this also

 

_________________

# 1997 EL Falcon GLI - 600+rwkw

# 2008 FPV FG GTE - Xa Coilovers, 20x8/ 20x10 Fairladys

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 12:29 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names