Fordmods Logo

Removing Wastegate Springs 


Page 1 of 1 [ 2 posts ] 

 Post subject: Removing Wastegate Springs
Posted: Tue Sep 12, 2006 1:50 am 
Getting Side Ways
User avatar

Posts: 426

Joined: 26th Jan 2005

Gallery: 4 images

Ride: EB GLi 4.0L

Location: Adelaide
SA, Australia

hey guys, heres a hypothetical situation :wink: a friend of mine, bob, wants to buy an external wastegate (probably a mosta 50mm 1000hp ebay one) however they only come with 8 or 10psi springs in them which is too high. the two fixes for this that bob can think of are:

1. go to a spring manufacturing joint and get them to make a spring that is weaker, or
2. remove the spring completely

bob is thinking seriously about the second option because its cheap. he's imagining that the result would be a wastegate that opens (probably to the full ammount) as soon as any boost is seen, is this the case? second thought, will the wastegate still operate without the spring, ie. the valve is still held central, diaphragm would move, etc and finally would a boost controller then be able to modify the "setting" of the wastegate?? (bob is only looking for low boost at his point in time such as 3-4psi)




EBII 4.0L GLi | T5 | 3.27 Spool | POD | KKK K27 Turbo | 600x300x76 FMIC | 40mm Wastegate (dead) | RPD Stg1 Cam | B&M Launch Control | Thermos | 3" Dump | Twin 2.25" Zorst | 197kw@3500rpm, 7psi LEAN!

To Come: Hydraulic Handbrake | Coilover Springs | Fuel Pump | Microtech MT8 | 455cc Injectors

Posted: Tue Sep 12, 2006 2:23 am 
Getting Side Ways

Age: 32

Posts: 868

Joined: 23rd Sep 2005

Ride: eb falcon

Location: kadina
SA, Australia

wastegate must have a spring, get city springs or somewhere to custom make it for you...

you need a spring to ovecome the backpressure from the exhaust manifold trying to push it open.. even if you apply equal boost pressure to the top and bottom of the diaphram, then the valve will still be free to move when pressure is applied to the valve.

if you applied pressure to the top side only, then sure it will push the valve shut, BUT only while you have boost, BIG trouble even making any boost with a wastegate thats wide open.. lol



EB 4L, 8.4:1, R154, GT4202r, 4in exhaust, Greenslade Engineering exhaust manifold, plenum chamber, 90mm throttle, Garrett W2A cooler, Surecam custom, autronic SM4, Bosch 120lb, Crane HI-6, LX-92, LM-1, Turbosmart Reg, 2x bosch 044, turbosmart 48 gate. 470kw+ @ 18PSI

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 12:46 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names