Fordmods Logo

Turo starts then stalls :( 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Turo starts then stalls :(
Posted: Thu Jan 20, 2011 8:56 pm 
Stock as a Rock
Offline

Age: 27

Posts: 130

Joined: 6th Jan 2008

Ride: 2 XF's, XE, EA Ghia

Location: Adelaide
SA, Australia

hi all turboed my car recently (Manual EB 3.9L) but last night blew my stock fuel pump (already knew this was gonna happen so bought an 044 bout a week ago but still tryin to find fittings) all well n good so i put a different stock fuel pump in my car just to get it home, didnt boost at all. so went to start it today an now it doesnt want to run for more than 15seconds max. the fuel pump primes an is pumping fuel but it just doesnt want to run. now ive checked a few fuses an relays, an cleaned my terminals but still nothing. also if you tap the accelerater a couple times whiles its running its very lagging, like u would tap it then 2 seconds later it would rev then die. its wierd was thinkin that there might be something in the fuel line an thats y its not running for long because its getting limited fuel. i dont know was hoping someone has had a similar problem an could give me some advice lol thanks
Top
 Profile  
 
 
 Post subject: Re: Turo starts then stalls :(
Posted: Fri Jan 21, 2011 8:21 am 
Getting Side Ways
Offline

Age: 36

Posts: 9453

Joined: 9th Nov 2004

Gallery: 4 images

Ride: Fordrunner 5.0 Turbo

Location: Wollongong
NSW, Australia

What's your fuel pressure like? Did you swap for an adjustable reg at all?

When was the last time you changed your fuel filter? Could be a blockage up stream or something.
Top
 Profile  
 
 
 Post subject: Re: Turo starts then stalls :(
Posted: Fri Jan 21, 2011 8:25 am 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

I'd put money on a fuel filter as well Xcabbi.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: Turo starts then stalls :(
Posted: Fri Jan 21, 2011 2:41 pm 
Stock as a Rock
Offline

Age: 27

Posts: 130

Joined: 6th Jan 2008

Ride: 2 XF's, XE, EA Ghia

Location: Adelaide
SA, Australia

ive got a 12:1 FMU. just changed filter then, it ran for longer but then still stalled.
Top
 Profile  
 
 
 Post subject: Re: Turo starts then stalls :(
Posted: Fri Jan 21, 2011 4:37 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

have you tested your fuel pressure? does the replacement pump actually work or is it just as lame as the unit it replaced? sounds like a fueling issue, or your air filter is inside a plastic bag.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: Turo starts then stalls :(
Posted: Fri Jan 21, 2011 9:16 pm 
Stock as a Rock
Offline

Age: 27

Posts: 130

Joined: 6th Jan 2008

Ride: 2 XF's, XE, EA Ghia

Location: Adelaide
SA, Australia

i replaced it with a stock one at the time but just finished installing my bosch 044 intank an it ran great for about 30seconds even got a few little revs out of it but sounded like it was missfiring. then it stalled an an wouldnt start again :| also the return out of my FMU was leaking abit as if the was something blocking it???
Top
 Profile  
 
 
 Post subject: Re: Turo starts then stalls :(
Posted: Sat Jan 22, 2011 8:57 am 
Smokin em up
Offline

Age: 32

Posts: 211

Joined: 21st Oct 2010

Ride: turbo falcon

Location: adelaide
SA, Australia

try removing the 12:1 reg and see how it goes, the cheap ones often stick etc. You need a fuel pressure gauge or you will only be guessing and blow your headgasket if it leans/pings on boost. You need to confirm higher fuel pressure on boost at minimum and would be better if you had a wideband hooked up as well. If you havnt already retard your base timing. My eb is set at 5degrees instead of factory 10 untill my j3 gets here. Factory timing would ping on mine with anymore than 6psi.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 1:20 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names