Fordmods Logo

302 W HO oil pressure/ sender issues... 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: 302 W HO oil pressure/ sender issues...
Posted: Sun Feb 03, 2013 3:00 am 
Stock as a Rock
Offline
User avatar

Age: 32

Posts: 197

Joined: 10th Jul 2011

Gallery: 2 images

Ride: Always Falcons.

Location: Melbourne
VIC, Australia

Hopefully someone can point me in right path before I go ripping apart everything apart...

I have an EF2 XR8 that the guage shows me worrying readings now and then... Sometimes sitting at lights, its normal and steady, other times its very low (but not red) and while driving its like it rises with revs, but right up... Is this my sender playing up, or pick up/oil blockages/?

Another of my cars is a EF fairmont ghia V8, and the guage on that is just plain stupid, like a frog in a sock constantly, but I assume this is just dodgey sender?

Thanks for any suggestions/advise...

 

_________________

EF2 XR8 Lowered on Genuine EL GT 17", Slotted + Drilled all round, Custom retrimmed ghia interior, competition stereo, DiFillipo headers, hi-flow cats, single muffler 3", K&N, custom maf/induction and rear window venetian

Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Sun Feb 03, 2013 9:48 am 
Smokin em up
Offline

Age: 37

Posts: 284

Joined: 3rd Mar 2012

Ride: NL Fairlane Ghia V8

Location: Geelong
VIC, Australia

Mine does the same, so I just bought a new oil pressure sender/switch. Ford still stock them, was about $40 with employee discount.
Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Sun Feb 03, 2013 11:06 am 
Stock as a Rock
Offline
User avatar

Age: 32

Posts: 197

Joined: 10th Jul 2011

Gallery: 2 images

Ride: Always Falcons.

Location: Melbourne
VIC, Australia

And the new sender fixed the problem? Its now a steady constant reading?

 

_________________

EF2 XR8 Lowered on Genuine EL GT 17", Slotted + Drilled all round, Custom retrimmed ghia interior, competition stereo, DiFillipo headers, hi-flow cats, single muffler 3", K&N, custom maf/induction and rear window venetian

Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Sun Feb 03, 2013 12:29 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

9/10 times it will, 2 other things to check are..

1. Put a mechanical gauge on it and make sure it actually has a sender issue and not an actual oil pressure issue,

2. Check your earths.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Sun Feb 03, 2013 1:08 pm 
Stock as a Rock
Offline
User avatar

Age: 32

Posts: 197

Joined: 10th Jul 2011

Gallery: 2 images

Ride: Always Falcons.

Location: Melbourne
VIC, Australia

Thanks, although its never gone "red", I still dont like the fluctuating needle... Ill see how I go...
What would cause oil pressure issues? Its level (full) and reg serviced...
Just trying to tidy up the last owners mess, get it everything nice.

 

_________________

EF2 XR8 Lowered on Genuine EL GT 17", Slotted + Drilled all round, Custom retrimmed ghia interior, competition stereo, DiFillipo headers, hi-flow cats, single muffler 3", K&N, custom maf/induction and rear window venetian

Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Mon Feb 04, 2013 9:12 am 
Smokin em up
Offline

Age: 37

Posts: 284

Joined: 3rd Mar 2012

Ride: NL Fairlane Ghia V8

Location: Geelong
VIC, Australia

TFORD8 wrote:
And the new sender fixed the problem? Its now a steady constant reading?

I'll let you know on saturday when I fit it. Can't see it being anything else cause it would be ok most of the time and then swing around like a retarded monkey the next.
Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Mon Feb 04, 2013 12:53 pm 
Stock as a Rock
Offline
User avatar

Age: 32

Posts: 197

Joined: 10th Jul 2011

Gallery: 2 images

Ride: Always Falcons.

Location: Melbourne
VIC, Australia

NLGHIA5.0 wrote:
TFORD8 wrote:
And the new sender fixed the problem? Its now a steady constant reading?

I'll let you know on saturday when I fit it. Can't see it being anything else cause it would be ok most of the time and then swing around like a retarded monkey the next.

Haha, yep, sounds the same.

 

_________________

EF2 XR8 Lowered on Genuine EL GT 17", Slotted + Drilled all round, Custom retrimmed ghia interior, competition stereo, DiFillipo headers, hi-flow cats, single muffler 3", K&N, custom maf/induction and rear window venetian

Top
 Profile  
 
 
 Post subject: Re: 302 W HO oil pressure/ sender issues...
Posted: Mon Feb 04, 2013 9:42 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

and dont forget - if you dont replace the sender when it starts doing this you'll probably end up with an oil leak when the oil eventually pushes past the mylar disc, and the casing of the sender.

on my XR8 it was running straight onto the cats...
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 6:43 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names