Fordmods Logo

351 efi troubleshooting 


Page 1 of 1 [ 3 posts ] 

 Post subject: 351 efi troubleshooting
Posted: Tue Dec 16, 2008 9:37 pm 
Fordmods Newbie

Age: 59

Posts: 1

Joined: 30th Sep 2008

Ride: f250

Location: brisbane
QLD, Australia

Ihave a 92 f250 351 efi ex ambo . The vehicle blows black smoke,air is coming out the emission system under the bonnet and the EEC light is on. Tried to do a self diagnostic test but found the fuel pump would not turn off so i couldn't get any codes. Any ideas where to start.
Posted: Wed Dec 17, 2008 11:48 am 
EFI Guru

Age: 51

Posts: 4186

Joined: 5th Nov 2004

Gallery: 24 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Could be a number of things.
Does the fuel pump run all the time when it's not in self test mode?
If not you may have just picked the wrong pin in the diag connector and grounded the fuel pump.
Otherwise you could have a busted line on one of the thermactor emissions solenoid hoses causing a vacuum leak and because it's speed density it will run rich...explaining your black smoke.
Posted: Mon Dec 22, 2008 12:43 pm 
Oompa Loompa

Posts: 42

Joined: 15th Jun 2006

Location: Sydney
NSW, Australia

checked that your fuel pressure isnt too high?
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 12:35 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names