Fordmods Logo

5.4l back together no spark 

 

Page 2 of 2 [ 21 posts ] Go to page Previous  1, 2

 
 Post subject: Re: 5.4l back together no spark
Posted: Fri Feb 15, 2013 2:44 pm 
Fordmods Newbie
Offline

Age: 34

Posts: 17

Joined: 30th Jul 2012

Ride: ba fairmont ghia 3vm

Location: bateau bay
NSW, Australia

professional daignostic done and connectors ,spark,fuel checked,
mechs tester says is fault with ecu. $77.35 came to us
i need a second hand ecu
ford can reprogram it for $150
ringin around wreckers
its hard to read the part number on the ecu because some wrecker at some stage has scribbled on it with texta
from what i can gather its
3r23-124650-fd
the scribble is f e's and l's
Top
 Profile  
 
 
 Post subject: Re: 5.4l back together no spark
Posted: Fri Feb 15, 2013 11:09 pm 
Oompa Loompa
Offline

Posts: 26

Joined: 8th Sep 2012

Ride: 2006 BF Mk1 XR8

Location: Sydney
NSW, Australia

Thing about proper scanners is they have the ability to select which ECU to talk too and are configured with the right coding to pull all the data from that ECU and display it, rather than the home scanner that generally just uses a global OBDII method and basically gets what the car will let it have.

for instance using Torque on an Android phone with a bluetooth elm32 bluetooth connector, you'll get a fair amount of Engine data (mainly just info about how the engines running, like temps and things), but no Body/Audio/HIM/Cluster/ABS|DSC/Etc data. Plus theres still lots of data in the engine ECU you won't see. Plus most scanners these days can do the security programing/linking (aswell as car "behavior" chages (like enable/disable auto headlights/taxi|cop mode/reprogram HIM to Single/Dual zone/etc)

Thats why taking it to an auto elec (who generally have atleast one of these types of scanner) is the best bet. I'd stay clear of ford purely because of their cost :O just to do what an auto elec will do for half the price (plus they generally truely know what they're doing, half the mechanics trained in the last 5 years just follow printed out flow charts, and if they don't the good ones will just let you take the car without charging you for something they can't do)

Definitely not surprised its the engine ECU (or PCM as they would say, exact same thing :P just like BCM and BEM....)

Lets just hope you didn't fry any of the other computers in the car too, as they're all interconnected (via canbus) and if ones not doing its job, the car still may not start or might do weird things
Top
 Profile  
 
 
 Post subject: Re: 5.4l back together no spark
Posted: Mon Feb 18, 2013 3:42 pm 
Fordmods Newbie
Offline

Age: 34

Posts: 17

Joined: 30th Jul 2012

Ride: ba fairmont ghia 3vm

Location: bateau bay
NSW, Australia

V8Enthusiast wrote:
Thing about proper scanners is they have the ability to select which ECU to talk too and are configured with the right coding to pull all the data from that ECU and display it, rather than the home scanner that generally just uses a global OBDII method and basically gets what the car will let it have.

for instance using Torque on an Android phone with a bluetooth elm32 bluetooth connector, you'll get a fair amount of Engine data (mainly just info about how the engines running, like temps and things), but no Body/Audio/HIM/Cluster/ABS|DSC/Etc data. Plus theres still lots of data in the engine ECU you won't see. Plus most scanners these days can do the security programing/linking (aswell as car "behavior" chages (like enable/disable auto headlights/taxi|cop mode/reprogram HIM to Single/Dual zone/etc)

Thats why taking it to an auto elec (who generally have atleast one of these types of scanner) is the best bet. I'd stay clear of ford purely because of their cost :O just to do what an auto elec will do for half the price (plus they generally truely know what they're doing, half the mechanics trained in the last 5 years just follow printed out flow charts, and if they don't the good ones will just let you take the car without charging you for something they can't do)

Definitely not surprised its the engine ECU (or PCM as they would say, exact same thing :P just like BCM and BEM....)

Lets just hope you didn't fry any of the other computers in the car too, as they're all interconnected (via canbus) and if ones not doing its job, the car still may not start or might do weird things


everything bem and him wise seems to be working so fingers crossed aye.
the remote works but I don't have a second to see if will relearn .
maybe the pcm only sees voltage when cars off some other things don't I dunno ..
all autolekos ive been talking on the coast have to either have to send both ecus away or send it to ford. might ring ultratune see what they reckon.
the pcm communicates . its just not throwing any codes or providing spark or injector pulse
which sucks kinda it could just be dead !
if something wernt plugged in it would throw open circuit codes.
its proving a efing pain to find and pcm that's suits. fraud want 1600 installed for a new1 no way !
if anyones reading and you got one that's not ridiculously priced pm me please .
doin some usa reading this (no fuel no spark)usally happens when you forget to plug the knock sensor back in ,
except ba's don't have knock sensors I believe.well mine didn't when I pulled it apart.
the only sensors was on the sump ,oilfilter housing ,the timing cover,drivers head and inlet manifold. but yeah no codes so all pointless really.
Top
 Profile  
 
 
 Post subject: Re: 5.4l back together no spark
Posted: Mon Feb 18, 2013 10:54 pm 
Oompa Loompa
Offline

Posts: 26

Joined: 8th Sep 2012

Ride: 2006 BF Mk1 XR8

Location: Sydney
NSW, Australia

i know the Boss motors have knock sensors, think it even got extra knock sensors in the BF model, possibly right that the 220 doesn't

Your right though if somethings not plugged in the computer should throw a code stating its open circuit (or shorted to ground/power/etc if its damaged or wiring is damaged, or atleast a code along the lines of incorrect signal/etc if a sensor like the crank was making a weird signal).

But, if somethings burnt in the computer, like the actual main earth for the output to fire the coil, generally computers aren't setup to see that monitor that (though that is changing these days too so)

Definitely a hard one, really comes down to elimination, if everything else checks out fine, gotta be something wrong with the computer.

Only thing i can think of is to get your self a Scope, prob the sensors them selves and check and see if theres an actual signal coming out of sensor, if there is, and you check the same wires at the PCM end of the harness and the signal is there where it enters the pcm but nothing is happening, has to be PCM.

funny how much damage a reverse in polarity even for a second can do isn't it :cry: :cry: :cry:
(my sisters husband did the same thing on a N16 pulsar once, killed the reg in the alternator (not the diodes luckily) and of all things, shorted the Horn Relay out....which laid unfound till they tried to beep someone, where it immediately lit up the clockspring in the steeringwheel! No horn/airbag lights/etc, 2 second whoopsie causes all that damage :(
Top
 Profile  
 
 
 Post subject: Re: 5.4l back together no spark
Posted: Mon Feb 18, 2013 11:19 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

That's correct BA doesn't have Knock detection but BF does.
The scribbling of code on the PCM sticker is usually done by Ford when an updated cal is programmed to the PCM.
Top
 Profile  
 
 
 Post subject: Re: 5.4l back together no spark
Posted: Tue Feb 19, 2013 12:52 am 
Fordmods Newbie
Offline

Age: 34

Posts: 17

Joined: 30th Jul 2012

Ride: ba fairmont ghia 3vm

Location: bateau bay
NSW, Australia

V8Enthusiast wrote:
i know the Boss motors have knock sensors, think it even got extra knock sensors in the BF model, possibly right that the 220 doesn't

Your right though if somethings not plugged in the computer should throw a code stating its open circuit (or shorted to ground/power/etc if its damaged or wiring is damaged, or atleast a code along the lines of incorrect signal/etc if a sensor like the crank was making a weird signal).

But, if somethings burnt in the computer, like the actual main earth for the output to fire the coil, generally computers aren't setup to see that monitor that (though that is changing these days too so)

Definitely a hard one, really comes down to elimination, if everything else checks out fine, gotta be something wrong with the computer.

Only thing i can think of is to get your self a Scope, prob the sensors them selves and check and see if theres an actual signal coming out of sensor, if there is, and you check the same wires at the PCM end of the harness and the signal is there where it enters the pcm but nothing is happening, has to be PCM.

funny how much damage a reverse in polarity even for a second can do isn't it :cry: :cry: :cry:
(my sisters husband did the same thing on a N16 pulsar once, killed the reg in the alternator (not the diodes luckily) and of all things, shorted the Horn Relay out....which laid unfound till they tried to beep someone, where it immediately lit up the clockspring in the steeringwheel! No horn/airbag lights/etc, 2 second whoopsie causes all that damage :(


pointless babble:
I shoulda just left it unlocked but other half wanted it
I was all like all the sensors are unplugged and plugs laying everywhere it will probably frig it but I went ahead against my judgement only to find the battery was flat .
so my other half says why don't u grab the new battery out of your Fairmont so I did an the rest is history I frigged it at the worst possible time with the engine stripped bare .
no one could steal it was in the car port without heads lol its insured anyway. I just didn't lock all the doors before I started so I could use the key on the drivers door.
she got the s**t now cause it was running before not now,
more like rattle and run.
tensioners had blown
the old chain had a semi seized link ,the drivers guide was shattered,the drivers chain had started to make a new guide in the timing cover :shock: the heads were coked and crusty ,rocker covers coked and blocked,
there wasn't much displacement left in the thing 5mm of carbon on the pistons,carbon rings from hell ,carbon in the bowls,solid ash filled valves ,spattery seats and s**t seals.injectors were coked,inlet manifold filthy .
now its all clean all new parts brands ectectect , upgraded bolts ,upgraded gaskets and heads and valves recoed,mobil gold extended 5-30 fullsyn oil.
just doesn't go. surprisingly before I molested it didn't blow any smoke just sounded embarassingly horrible in the drive threw was a second slow and hesitated .
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 21 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 7:34 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names