Fordmods Logo

ah the first service i get to do to my baby!! 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: ah the first service i get to do to my baby!!
Posted: Thu Feb 23, 2006 9:07 pm 
Technical Contributor
Offline
User avatar

Age: 34

Posts: 4355

Joined: 14th Dec 2005

Gallery: 36 images

Ride: Fairlane

Location: Newy
NSW, Australia

i know this has been posted plenty of times, but i did a search and just couldnt find exactly what i was looking for.

on the weekend i will be doing service on the car... 8-)

what do u recommend?

i have read about 9mm and 10.5mm leads, with the only difference in 10.5 having more insulation. what advantage would this have? what would be a good brand to buy? and how much approx?

plugs, are the standard NGK plugs anygood that u get from any old atuo parts joint, just the standard ones? i dont think i will go the ones that last ages, as i cant justify the price..

oil and filter. What is the best oil to use, i use to use shell red (cant remember the name) oil in the old Eb, but didnt overly impress me. And what oil filter should i get, i heard the standard ones from ryco are complete s**t. but not sure or any other brands.

Coolant, what coolant do you reccomend? i used to just use the s**t $5 s**t,but i wouldnt mind getting something a bit better.



cheers boys

 

_________________

The Lane Lives.... Finally!!!!

Top
 Profile  
 
 
Posted: Thu Feb 23, 2006 9:10 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 5313

Joined: 6th Nov 2004

Gallery: 4 images

Ride: Surf, Turbo Diesel

Location: Melbourne, S.E Suburbs
VIC, Australia

oil - i just used magnetec...

with spark plugs make sure you check the gap..
everytime i get a packet that say they are made for the car, always have the wrong gap..
so check the gap..

coolant, umm castrol (i think its them) have a good one

 

_________________

Image

Top
 Profile  
 
 
Posted: Thu Feb 23, 2006 9:15 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 695

Joined: 5th Nov 2004

Gallery: 7 images

Ride: 2008 WQ Fiesta XR4

Location: Adelaide.
SA, Australia

10.5 mm leads would be a waste of time on a mostly stock motor, I'd stick with the 9mm leads and save some money.
I use the standard NGK plugs and have no trouble with them either, good plugs and I can live with replacing them more frequently.
Strange you've heard negative comments about the Ryco oil filter. I've never heard of them being bad, I've always used a Z9 Ryco and have been happy. Oil wise, don't go for anything too thin. I use the semi-synthetic Shell Helix, not sure what colour bottle that is, think its the silver one.
Get some good coolant in there too, give the motor and radiator a flush and fill it with Tectaloy 90+ or something equivelant. I only buy the premixed ones, I won't let Adelaide water anywhere near my cooling system!

 

_________________

2008 WQ Fiesta XR4
2007 LS Focus CL

Top
 Profile  
 
 
Posted: Thu Feb 23, 2006 9:22 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

yeah grab the castrol concentrate coolant on the little ring pull tin..

oil, you get what you pay for, or are you asking what grade,

and yeah check the gaps,

also when you put your wheels back on if tou take em off make sure you put on the right way.. (chunkz knows this one) sorry mate its still going.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
Posted: Thu Feb 23, 2006 10:07 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

oil filter i always use genuine stuff, even a genuine AFL 1 MC filter retails for less then $10.

plugs, as has been said the NGK ones are okay, but yes make sure u do check the gap.

leads - if there is nothing wrong with your existing leads what do u hope to gain by changing them?

coolant - again i'd use genuine, but other decent stuff should be okay, make sure u actually flush the cooling system as opposed to draining and refilling it.
Top
 Profile  
 
 
Posted: Fri Feb 24, 2006 5:46 am 
Technical Contributor
Offline
User avatar

Age: 34

Posts: 4355

Joined: 14th Dec 2005

Gallery: 36 images

Ride: Fairlane

Location: Newy
NSW, Australia

the leads that are on it are the original leads... so i think it is time for a change, seeing how it will be 8 years old next month.

and yeah what grade oil to use would be great.

 

_________________

The Lane Lives.... Finally!!!!

Top
 Profile  
 
 
Posted: Fri Feb 24, 2006 6:55 pm 
Oompa Loompa
Offline

Age: 37

Posts: 26

Joined: 17th Dec 2005

Gallery: 3 images

Ride: EL GT

Location: Sydney
NSW, Australia

In Australia you don't really need a thin oil.
I use 15w50 in mine. I use the Valvoline Durablend.
With filters any of the known brands are decent. Such as Ryco.
I use a Fleetguard LF3487. It's not paper media it uses Microglass (synthetic). It's overkill on a Pushrod 5Ltr but ever since Dean Canto
started bying them off me a few years ago for his race cars i figured
i may as well use 'em since i pay stuff all for 'em.
Leads are a waste of money unless they are busted or you're building a big Hp motor.
I'd use genuine or Iridium plugs for the fact that they're a pain in the a*** to change on the 5Ltr engines.
Check your belt, tensioners and idler pulleys. They wear a fair bit.

Have fun. :D
Top
 Profile  
 
 
Posted: Fri Feb 24, 2006 6:57 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

factory spec is 15w/40 or 20w/50 so i certainly wouldnt put anything thinner then 15/40 in a stock engine, but yeh. i'd run 15w/40.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 11:28 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names