Fordmods Logo

AU Fan speed controller is dead, fans WONT turn off. 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: AU Fan speed controller is dead, fans WONT turn off.
Posted: Mon Oct 24, 2011 7:12 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

While I doubt this is solely V8 related, it appears my Fan Speed Controller is cactus, Symptoms are...

1. A/C Fans do not turn off.
-This is the case weather I have the car running or not running, Keys in the ignition or not.

seems the only way to stop it is to disconnect the battery.

I have 2 questions, What fuse or relay can I pull to stop the fans. I understand thay will not work at all, but at least I can lock my car up without fear it will drain the battery.

Secondly,

Where is, and how do I replace the fan speed controller. I understand it resides somewhere behind the glovebox, but that is where my knowledge of all this ends. I know there are some wise heads with the answers, i am hoping some of you can impart some knowledge on how to fix this, and perhaps someone in the Sydney region who knows what they are doing and prepared to lend a hand.

If its a piss easy job, I can tackle it myself I just need to know what to do.

On a side note, I have put the Climate unit into test mode, but I am unable to read any codes due to dropped sectors on the stupid screen.

Cheers,

Dave

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Tue Oct 25, 2011 1:52 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3452

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

Dave;
You can't buy the controller but I was told by disconnecting the wires from the controller should fix the problem.

Attachment:
Heater.JPG
Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Tue Oct 25, 2011 3:21 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

they look the same as e series?
having climate control wouldnt the speed controler be different to std??
Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Tue Oct 25, 2011 3:26 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

Let me guess, that second screw on the controller is a mongrel to get to.

Ash, if you could post it, it would be much appreciated.

Let me know how much via PM, thanks for all your help both Ash and George. The spammer, you can go to hell.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Tue Oct 25, 2011 5:56 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

Just got home and checked. no sweat, next time your in town.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Fri Oct 28, 2011 9:20 am 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

Damn you for being right Tory. I got the part that Ash sent. Huge Thanks for that BTW.

AU with climate control is a different unit again.

Image

Image

I have contacted Papa Smurf to get a part number a price it up. Fortunatly, the weather this week as not seen the need to have AC or even fans running. so I have gotten away without.

12 years out of an item that is exposed to the elements is not too bad I think.

Lets hope ford still stocks these items. For my sake.

Dave

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Fri Oct 28, 2011 2:42 pm 
Getting Side Ways
Offline
User avatar

Posts: 450

Joined: 24th Jan 2009

Ride: BF wagon

Location: western sydney
NSW, Australia

There is also a thread on AFF (by Lil monty) about restoring the missing segments for climate control. I used this method and fixed mine in the fairmont. Alternativly there is a mob on Ebay that do an exchange climate control, yours being for the TE shouldnt matter as you just swap the casings (woodgrain for carbon look).
Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Fri Oct 28, 2011 3:24 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

dc_todd wrote:
Damn you for being right Tory. I got the part that Ash sent. Huge Thanks for that BTW. AU with climate control is a different unit again.
I have contacted Papa Smurf to get a part number a price it up. Fortunatly, the weather this week as not seen the need to have AC or even fans running. so I have gotten away without.
12 years out of an item that is exposed to the elements is not too bad I think.
Lets hope ford still stocks these items. For my sake.
The part Ash sent you is a std resistor setup - the fan speed controller in the pic with the power transistor does look same as E series - probably you could swap the guts around if the wiring isn't identical - there's a few E series fairmonts and Fairlanes at PNPL.
From memory, there might be an AU fairlane/ghia display as well - check their website.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: AU Fan speed controller is dead, fans WONT turn off.
Posted: Fri Oct 28, 2011 3:32 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

Aquired another today from a wrecker. Well scored as well. I will put that one in, refirbish mine and reinstall it, doing a refirbish on the spare one for the parts shelf or someone who runs into the same issue, it will be onsold on an exhange basis.

I guess this will end up in the garage thread when I get around to it all. Gotta wait for this other one to be delivered. But this thread should serve as a useful reference to those in future who have issues. Very little info around out there in relation to this.

 

_________________

Image

I have a car.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:58 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names