Fordmods Logo

BA XR8 Crank Angle Sensor 


Page 1 of 1 [ 4 posts ] 

 Post subject: BA XR8 Crank Angle Sensor
Posted: Thu Nov 25, 2004 9:06 pm 
Fordmods Newbie

Posts: 1

Joined: 25th Nov 2004

Location: Brisbane
QLD, Australia

On going problem with my 2003 XR8, and appears to be tied up with the Crank Angle sensor.

It has had a very difficult problem to trace, and symptoms being hard starting when cold, poor running, miss fire, no power, last for about 20 minutes, and I mean runs like a dog!! then shut down start up and its full of power, runs like it never had a problem. NO fault code found by Ford, and has been on going for 8 months. No longer funny!!!

However it was found that the CAS had watter in the connection. Any idea if this will casue this problem, and any one had experience with or heard of this sensor playing up. Any thoughts

Posted: Fri Nov 26, 2004 1:25 am 
Fordmods Junkie
User avatar

Age: 37

Posts: 1000460

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

dunno could be
maybe replace it and see
cant see how water would stuff it up
i regualr wash/degress engine on mu i6 and spray water all over the CAS and had no worries
replace it and c?




Posted: Fri Nov 26, 2004 10:42 am 
Fordmods Newbie

Posts: 5

Joined: 25th Nov 2004

Ride: BA XR8 Ute

Location: Geelong
VIC, Australia

Sounds like either plug leads or the CAS. I had a similar drama a few years ago in the work car (VT wagon). It would shut down when running down the freeway or stuck at the lights or it didn't really matter where or when. But it was traced down to the CAS which was then replaced and no dramas since. We've had a few at work with the same faulty CAS being replaced. Wouldn't suprise me if it was a similar problem on the Boss.
Posted: Fri Nov 26, 2004 10:54 am 
Getting Side Ways
User avatar

Age: 35

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

Had a bloke down here from Sydney for drags a few months back. Had BA GT, few herrods bits n pieces but wasnt to his expectations.

Anyways, took it into ford to have a look at, turns out one of the four cams was not sitting right. Apparantley one tooth away from where it should have been.

May be worth looking into.



I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 2:11 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names