Fordmods Logo

eb series 2 annoying abs light 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: eb series 2 annoying abs light
Posted: Tue Jan 08, 2013 10:05 pm 
Oompa Loompa
Offline

Age: 32

Posts: 21

Joined: 27th Feb 2012

Ride: 5.0L eb fairmont ghia, xe ute

Location: gold coast
QLD, Australia

I have a 93 series 2 fairmont ghia 5.0 and some time ago the abs light just come on and has stayed on ever since does anyone have any ideas as to what causes this
Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Wed Jan 09, 2013 11:44 am 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

check the sensors behind the brake rotors, sometimes they get cloged up with brake dust and fine metal as they are magnetic sensors...
Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Fri Jan 11, 2013 9:38 pm 
Oompa Loompa
Offline

Age: 35

Posts: 26

Joined: 23rd Dec 2011

Gallery: 1 images

Ride: NC Fairlane Ghia

Location: townsville
QLD, Australia

my 93 nc fairlane has the same problem, I cleaned all 4 sensors and its still on, have you replaced the brake rotors by any chance?

 

_________________

I'll show you I'm Australian if you show me your Brazilian

Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Mon Jan 14, 2013 1:01 am 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1938

Joined: 10th Nov 2004

Gallery: 31 images

Ride: G6E TURBO

Location: THE DRUITT
NSW, Australia

I also have the same issue, I have changed the brake fluid, fitted new front rotors and saw fine metal on the sensors and cleaned it off. Still the abs light will not clear on most times of starting the ignition and if the car starts with out the light on then the brake pressure screws around and the pedal goes hard unit the light comes on then the pedal will have movement.

 

_________________

MEMBER 1390

Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Mon Jan 14, 2013 11:16 pm 
Oompa Loompa
Offline

Age: 35

Posts: 26

Joined: 23rd Dec 2011

Gallery: 1 images

Ride: NC Fairlane Ghia

Location: townsville
QLD, Australia

Was it on before you changed the rotors?

 

_________________

I'll show you I'm Australian if you show me your Brazilian

Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Tue Jan 15, 2013 12:02 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

Have you tried to do a fault code scan to see what the fault code is? Might be a better idea than guessing.

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Wed Jan 16, 2013 6:07 pm 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1938

Joined: 10th Nov 2004

Gallery: 31 images

Ride: G6E TURBO

Location: THE DRUITT
NSW, Australia

ncfairlane5.0 wrote:
Was it on before you changed the rotors?

Before and after changing the front rotors.

 

_________________

MEMBER 1390

Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Fri Jan 18, 2013 12:10 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

Run a codes scan, but maybe the front sensors are buggered?

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: eb series 2 annoying abs light
Posted: Fri Jan 18, 2013 7:06 pm 
Oompa Loompa
Offline

Age: 32

Posts: 21

Joined: 27th Feb 2012

Ride: 5.0L eb fairmont ghia, xe ute

Location: gold coast
QLD, Australia

I changed the rotors on mine about 1 year ago and the light come on but I worked out they had sold me non abs rotors so I returned them and got the right ones I installed them and the light went off then about 6 months later the light come on and has stayed on ever since
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 5:14 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names