Fordmods Logo

EBXR8 Missing when hot... 

 

Page 1 of 2 [ 19 posts ] Go to page 1, 2  Next

 
 Post subject: EBXR8 Missing when hot...
Posted: Tue Feb 14, 2012 11:53 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

Gday all,

HAve got an issue with the falcon(series 1 EB XR8 on LPG injection). I start no probs on petrol and clicks over to LPG normally once warm. However, sometimes when I go to start the car(initial start s on petrol - 98RON), it will start ok but change into a gear and it runs on one or two cylinders and is real rough. Once on LPG, all is well but change it back to fuel and back to the burping and f@rt.

I changed the plugs/leads, fuel filter and checked for vacuum leaks - still being a b**ch.

Help appreciated.
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Sat Feb 18, 2012 11:50 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

Anyone????
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Mon Feb 20, 2012 9:40 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Need more info really.
Does your fuel pump turn off when on LPG?
Could be the pump failing when it's hot?
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Mon Feb 20, 2012 10:18 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

Newpump installed 5000km ago(Warnbro)
Changed all lines and filters(old ones had seen better days...)
New plugs and leads
Rotor button changed
Dizzy cap is the next thing to be done
Pump shuts off once the injectors for the gas click in
The petrol injectors keep running in conjunction with the gas but no pump
I think I may have to get new injectors for the old girl as they are the original ones
If I rev the tits off it it comes good after a few seconds but will run a little down on the power
Cold is fine and also if let stand for at least an hour before starting up.
Once on gas, runs perfectly

Cheers
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Mon Feb 20, 2012 10:20 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

Sorry - another Q - what would be the best recommendation for replacement injectors? I have no idea in this area and will be getting a mechanic to do it. I won't refurbish so new ones will be ordered.

Cheers again
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Mon Feb 20, 2012 10:27 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Yeah running the injectors without fuel running through them will kill them. It's likely they play up after the engine is hot in this case. Get new ones from the U.S., they charge too much for them here.
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Mon Feb 20, 2012 11:25 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

XR9UTE wrote:
Yeah running the injectors without fuel running through them will kill them. It's likely they play up after the engine is hot in this case. Get new ones from the U.S., they charge too much for them here.

Thanks for that - any suggestions for a replacement injector? Money isn't an object but have to be sensible in sourcing a replacement. Do I remain with the STD ones or can I go a little bigger? I am mindful at the moment as I am putting HITECH headers on the car in a couple of days so will probably need a good tune once it is connected.

Thanks again - Cheers
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Mon Feb 20, 2012 11:25 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

XR9UTE wrote:
Yeah running the injectors without fuel running through them will kill them. It's likely they play up after the engine is hot in this case. Get new ones from the U.S., they charge too much for them here.

Thanks for that - any suggestions for a replacement injector? Money isn't an object but have to be sensible in sourcing a replacement. Do I remain with the STD ones or can I go a little bigger? I am mindful at the moment as I am putting HITECH headers on the car in a couple of days so will probably need a good tune once it is connected.

Thanks again - Cheers
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Tue Feb 21, 2012 12:37 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Just std. 19's unless you change heads etc.
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Tue Feb 21, 2012 3:32 pm 
Getting Side Ways
Offline

Posts: 699

Joined: 1st Jan 2006

Ride: Lots, all Fords

Location: Hamilton
New Zealand

Re-wire the LPG so that the fuel pump runs when the engine is running, but the injectors are not powered.

 

_________________

XA Faimont 351C, AU2 XR8 Manual 5.0, DA LTD 5.0, Mk1 Capri 5.0, 1995 Mustang 5.0, EF2 XR8 Manual, EF2 Fairmont Ghia 5.0, AU3 XR8 Auto, AU2 XR8 Auto, AU2 XR8 Manual Ute, TE Cortina 5.0 Manual, DU LTD 5.0 soon to be manual

Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Tue Feb 21, 2012 10:43 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Yeah, if you're only using the petrol system for warm up til LPG takes over, then most likely the petrol injectors are dirty - particularly if they're originals as you say.
I would've thought the SVI LPG ECU would shut down the petrol injectors, as most are setup to monitor the petrol injector output, and modify the output for the LPG injectors.
As for shutting down the fuel pump, there's pro's and cons - if it's running and the petrol injectors are shut down, the excess fuel is returned back to the tank, it's probably good to have petrol circulating like that.
I'm for shutting down - haven't had any issues with petrol pumps over many years, but each to their own I guess.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Tue Mar 27, 2012 7:36 am 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

Well it looks like they have found some of the issues with the car. The intake manifold came off and the mechanic was greeted with a heavily sooted intake and lots of grimy carbon buildup. Seems the scavenging of the crankcase fumes has caused a buildup of grime inthe whole inlet manifold. It has been exasperated by a leaking EGR manifold gasket which has been dropping water into the inlet airflow further gumming up the works.

The injectors were also pulled as the electrical pulses were not right. The removed injectors were looked at and four of the eight were nearly completely blocked. New injectors installed and now awaiting a new EGR spacer(old one corroded beyond repair due to no coolant used by previous owner!!). Fuel was drained from the entire fuel system and tested - poor fuel quality and had gone right off. Tank was cleaned and came up ok so no need to replace the tank. New fuel pump and filter also fitted along with new hoses in the engine bay.

The mechanic will be taking it for a "spirited"drive to blow out the cobwebs and is using a upper cylinder cleaner used by the Army and their L-110's. Apparently it is the poop and leaves your intake spotless so will see how he goes.

More updates soon...

Hooroo
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Tue Mar 27, 2012 3:24 pm 
Getting Side Ways
Offline

Posts: 699

Joined: 1st Jan 2006

Ride: Lots, all Fords

Location: Hamilton
New Zealand

If the intake is already off, clean it in a solvent bath. Sending all that crap through your engine is a dumb idea. I have had good success using plain old H2O as an upper cylinder cleaner

 

_________________

XA Faimont 351C, AU2 XR8 Manual 5.0, DA LTD 5.0, Mk1 Capri 5.0, 1995 Mustang 5.0, EF2 XR8 Manual, EF2 Fairmont Ghia 5.0, AU3 XR8 Auto, AU2 XR8 Auto, AU2 XR8 Manual Ute, TE Cortina 5.0 Manual, DU LTD 5.0 soon to be manual

Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Fri Mar 30, 2012 8:11 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

xafalcon wrote:
If the intake is already off, clean it in a solvent bath. Sending all that crap through your engine is a dumb idea. I have had good success using plain old H2O as an upper cylinder cleaner


Well after all the work trying to sort out the issues, it came down to dirty fuel from Freedom Fuels(never again!!). I drained the fuel from the tank and had a weird green tinge to it and the smell was foul!! I ran it out to a friend at the airport who tested the fuel and had a lot of poop in it that wasnt supposed to be there:

Water
Manganese(??)WTF is this!?!
Tetra-ethyl lead(would have been good if it was the good stuff and mixed properly)
Some other ingredient that I cant even pronounce but it is an industrial solvent of some descript.
Way too much phosphorous apparently.

He said all said the water was the thing gumming up the works as it was blocking the fuel filter. I replaced the fuel with Shell V-Power and a bottle of Wynns injector and upper cylinder cleaner. It no longer stutters or falters on petrol and smells like petrol when burnt - not paint thinners.

Contacted freedom fuels here in QLD and they would like to see the report from the airport before they will cough up for the repairs($1200 plus a tank of fuel)but they have alluded they have heard of many other complaints regarding their fuel quality(out of Brisbane). So I will be hoping they come to the party. The proof is irrefuteable as it was analysed in the lab here in Toowoomba. Cost $400 out of my pocket but it is good insurance I reckon. Will see how this pans out and let you all know.

Another win today was the EGR valve and the gaskets. Water leak was fixed and no more water in the inlet manifold. The VDO injectors were inserted(20lb)and the car accellerates like a rocket again. Finally happy with how the car is running...just waiting on the next problem to arise.

Hooroo
Top
 Profile  
 
 
 Post subject: Re: EBXR8 Missing when hot...
Posted: Sun Apr 01, 2012 7:37 pm 
Smokin em up
Offline
User avatar

Age: 48

Posts: 205

Joined: 8th Dec 2009

Gallery: 1 images

Ride: EB XR8, Now Blown 1977 Mini S

Location: Toowoomba
QLD, Australia

f**k hell I am good at jinxing myself. No sooner had I typed the above reply the power steering starts playing up. Drops nearly all of the fluid out if the low pressure return banjo joint below the harmonic balancer. Is there an o ring in there I can fix it with?

To add insult to injury, the heater tap decided to let go also - broke off in my hand when I was moving some of the wiring about in the engine bay. I tell you I still have the 20-odd litres of s**t fuel here and I am sure this POS EB will make a great bonfire. The plastic Fraud one is so brittle it crumbles in your hand. Obviously Fraud likes to see us back in their workshops getting s**t fixed due to inferior parts.

I have ordered a new one from Gates and will arrive in Toowoomba in the morning - apparently the rep said the fraud ones are notorious for leaking and the plastic is not designed for the high heat of an engine bay...good on you Henry T Motherf*cker.

More time under the bonnet - will let you know how I go. :evil:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 7:34 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names