Fordmods Logo

Ef 5.0l no power and vibrates like hell 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Ef 5.0l no power and vibrates like hell
Posted: Tue Jan 14, 2014 6:16 pm 
Parts Gopher
Offline

Age: 32

Posts: 66

Joined: 15th Nov 2011

Gallery: 2 images

Ride: ford 1992 eb s

Location: south morang
VIC, Australia

Hey guys,
F#*+en hot isn't it.
Have a issue with my 5.0l.
When driving on days like today, on first start cars
all good. Drive for 5 mins at around 75-80kph and there's
a strange lack of power. Accelerator fully depressed at 80 in 5th just won't move.
Yes I know 5th isn't the best to accelerate, but normally it accelerates fairly quickly.
And the at 100kph is has front end shudder like a wheels unbalanced but there not
as I had tyres done on Christmas Eve.
Has anyone had a issue like this?
Or does anyone know or have an idea?
It's not the maf sensor as it does it connected or disconnected.
Could it be balancer?
Could it be dizzy?
I'm not sure where to start.
Any help is muchly appreciated.

 

_________________

new ride: 96 EF fairmont ghia 5.slow, quad pipe exhaust, full custom eb ghia interior, el gt steering wheel, el xr front and full genuine ticky kit. and its a 5 speed manual. with sunroof, and mods to come.

Top
 Profile  
 
 
 Post subject: Re: Ef 5.0l no power and vibrates like hell
Posted: Tue Jan 14, 2014 10:32 pm 
Getting Side Ways
Offline
User avatar

Age: 55

Posts: 1566

Joined: 12th Apr 2008

Gallery: 17 images

Ride: 5.0lt NF /351 ZD Fairlane

Location: Wattle Grove
NSW, Australia

I had the balancer go on my 5.0 NF it felt like it was running on 7 cylinders by the time I got it to my mate the mechanics workshop it felt like only six were working we checked all the leads etc but eventually found the balancer but it seems odd that the balancer would come and go like that.

 

_________________

Image
NF Fairlane with 5.0 and 5 speed goodness!
ZD build thread under construction at post1136180.html#p1136180

Top
 Profile  
 
 
 Post subject: Re: Ef 5.0l no power and vibrates like hell
Posted: Tue Jan 14, 2014 10:35 pm 
Getting Side Ways
Offline

Age: 41

Posts: 4629

Joined: 23rd Nov 2006

Gallery: 4 images

Ride: 5.0 AU's and 5.0 Maverick

Power: 139 rwkw

Location: Sydney West
NSW, Australia

Vacuum hose knocked off?
The vacuum supply to the heater tap in my old XH ute use to fall off all the time and give the same symptoms as you are getting.

 

_________________

xr6turnip wrote:
More people paid for a ride in a VT commodore then an AU Falcon so the VT is superior.
Based on that fact my Mum is the best around!

Top
 Profile  
 
 
 Post subject: Re: Ef 5.0l no power and vibrates like hell
Posted: Tue Jan 14, 2014 10:51 pm 
Parts Gopher
Offline

Age: 32

Posts: 66

Joined: 15th Nov 2011

Gallery: 2 images

Ride: ford 1992 eb s

Location: south morang
VIC, Australia

Vacuum hose to heater tap is sweet they are all connected.
Balancer might be starting to fail.
As up till just before Xmas it never done it.
Only just recently got worse and now the heat wave is here
with a/c on it's more pronounced.
Seems odd though that it vibrates through the front end to a point
where I actually have to grip the steering wheel that tight to try and control
the vibration through it.

 

_________________

new ride: 96 EF fairmont ghia 5.slow, quad pipe exhaust, full custom eb ghia interior, el gt steering wheel, el xr front and full genuine ticky kit. and its a 5 speed manual. with sunroof, and mods to come.

Top
 Profile  
 
 
 Post subject: Re: Ef 5.0l no power and vibrates like hell
Posted: Wed Jan 15, 2014 10:22 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Do a self test.
Could be fuel pump.
Top
 Profile  
 
 
 Post subject: Re: Ef 5.0l no power and vibrates like hell
Posted: Sat Feb 08, 2014 6:48 pm 
Fordmods Newbie
Offline

Age: 52

Posts: 6

Joined: 19th May 2013

Ride: AU3 XR8

Location: AUCKLAND
New Zealand

Have you tried the front brake caliper pistons they can swell up and jam on causing the rotors to heat up and warp giving massive vibration and also holding the car back.this happened to me
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 9:25 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names