Fordmods Logo

EF V8 Fairmont Ghia loss of power 

 

Page 1 of 2 [ 16 posts ] Go to page 1, 2  Next

 
 Post subject: EF V8 Fairmont Ghia loss of power
Posted: Thu Aug 03, 2006 9:39 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

I just bought a 96 EF Ghia 5 litre, it starts first go runs on all cylinders smoothly and has no noises or anything, but it just doesn't move like a V8 should... I also have a 6 cylinder EF and the 6 kills the V8... Something definately not right there... No engine light or anything... Puzzled
Top
 Profile  
 
 
Posted: Thu Aug 03, 2006 10:16 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 2280

Joined: 5th Nov 2004

Ride: EF Falcon 95

Location: Rosebud
VIC, Australia

more info mate, what sought of range are you getting to a tank of fuel, ie is it using alot of petrol, is it flat spotting anywhere? Does it run rough at all anywhere in the RPM range?

Check your regualr things, air filter, spark plugs, leads, oil filter, fuel filter, injectors. All these if not maintainted can cause a power loss.

 

_________________

Cougar Zero makes my pants fit nice.

Top
 Profile  
 
 
Posted: Thu Aug 03, 2006 10:46 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

Yeah.. just got the car today so haven't really checked the economy... The trip computer fuel usuage seems ok though.... It's not misfiring or running rough at all at any RPM it's just lazy... Otherwise I would have known if it was running on 7 cylinders or something... What you reckon I should check first
Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 12:37 am 
Getting Side Ways
Offline
User avatar

Age: 40

Posts: 1780

Joined: 31st Jan 2005

Gallery: 10 images

Ride: 07 BF mk2 E-gas wagon + eb 5.0

Power: 174 rwkw

Location: Adelaide
SA, Australia

have you had any experience with these v8's in the past. in stock form, which i assume it is, they aren't real flash. how many km's has it done. the trans may need looking at.

 

_________________

eb v8: low loud and fast. just how a v8 should be. i guess the big question is, is it fast enough...

Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 12:52 am 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

Tell you the truth it's my first ford I'm a holden man but come on it's gotta be faster then a 4 litre. I think it's in limp home mode or something, done 160k
Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 2:03 am 
Getting Side Ways
Offline

Age: 34

Posts: 1204

Joined: 9th Nov 2004

Gallery: 11 images

Ride: EL Fairmont Ghia V8 Turbo

Power: 303 rwkw

Location: Melbourne
VIC, Australia

Limp home mode it just sticks in third gear so i highly doubt it's stuck in that, you'll think the things gonna blow up just taking off from a stop.

I'd do maintenance stuff first, check leads, plugs, dizzy, air filter, fuel filter, clean maf wires....basic stuff but they are slugs in stock form and in no way are they easily quicker than a 4.0L....some are slower.

If you want a bit more punch i'd attack it with a set of extractors and a more free flowing exhaust, probably a single 2 1/2" to get started

 

_________________

EL Fairmont Ghia V8 Turbo 303rwkw
Image

Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 3:12 am 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

I used to do a lot of work on an EF XR8 for a guy a few years ago, i was sooooo disappointed in the performance of it being an "XR8" so called Tickford performance!!!
My 4.0 would have ripped it apart... anything from EB to series 1 EL in the 5.0 as stock are slugs.

In 89 my boss bought a brand new VN Calais 5.0, i drove that and i was impressed.... as soon as Ford brought out the EB 5.0 i went straight down to a dealer and test drove one, to me it was a bucket of s**t... back then if i had the cash and choice i would have gone the Holden, that's how bad it was.
Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 7:56 am 
Getting Side Ways
Offline

Age: 48

Posts: 655

Joined: 9th Jan 2005

Gallery: 5 images

Ride: Build# 499 BF F6 TYPHOON DEJA VU

Location: Melbourne
VIC, Australia

do what gutts said, i had the same problem, my leads were f**k and the button in the dizzy was burnt out, got that changed heaps better

 

_________________

232.5 RW KILLER WASPS

Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 8:10 am 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Swap your MAF out with someone else's and see if it improves because if its gone, the engine gets lazy.

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 12:43 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

Interesting.... I never heard of a 4 litre being faster than a 5 litre :S Weird.
Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 5:41 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

News just in - my mechanic reckons it's the torque converter
Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 7:13 pm 
Smokin em up
Offline

Age: 30

Posts: 259

Joined: 4th Apr 2006

Gallery: 12 images

Ride: 2002 XR8 manual

Location: Laurieton
NSW, Australia

prydey wrote:
have you had any experience with these v8's in the past. in stock form, which i assume it is, they aren't real flash. how many km's has it done. the trans may need looking at.


Maybe so, but.. i have an EL 5.0 Litre... and its completly stock... and it smokes a stock 6cyl falcon... (not by a great deal)... but they are still a few car lengths behind me after 100 meters.

 

_________________

AU XR8 manual.

Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 7:23 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

Cool... well this ones got problems, and a for laser would beat it, my transmission guy also said it could be the torque converter, or it may be in limp mode
Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 7:25 pm 
Smokin em up
Offline

Age: 30

Posts: 259

Joined: 4th Apr 2006

Gallery: 12 images

Ride: 2002 XR8 manual

Location: Laurieton
NSW, Australia

If you were in limp home mode, you would definatly know... as previously stated... it sticks in 3rd gear... and accelerating from a stop = dogballs

 

_________________

AU XR8 manual.

Top
 Profile  
 
 
Posted: Fri Aug 04, 2006 9:11 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 3rd Aug 2006

Location: syd
NSW, Australia

Oh k then it's definately not that, it just got no grunt at all, like too much to be from not having a tune up recently, somethings very wrong. But despite that it still idles and runs like new, that's why i'm thinking it's something to do with the trans (torque converter)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 16 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 10:11 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names