Fordmods Logo

EL FAIRMONT V8 strange engine behaviour 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EL FAIRMONT V8 strange engine behaviour
Posted: Sun Aug 10, 2014 9:02 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 10

Joined: 23rd Jun 2014

Ride: ford '96 fairmont ghia

Location: campbellfield
VIC, Australia

Hello, first time post. I have a EL Fairmont V8. Purchased a few months back and have added about 5000km to the clock which was at 303,000 km when i got it. I went right over it when i got it everything changed from radiator and hoses through to brake fluid.
I have noticed it has started to develop a ( missfire) at about 2500 rpm. The best way i can explain what it feels like is, if it had a carby on it u would think the jets on the secondarys where around 7 sizes to big.
I can drive the car 1/ 4 throttle and if i keep it under 2400 its not to bad. But push it any closer to the floor it bogs down. Engine will continue to rev to 4500 if i hold it but wouldnt pull the skin off a rice pudding and the sound is horrible. Reciently i have replaced the exhaust new 21/2 inch from cats back. The issue started a few weeks after this though. To fix the issue i have checked the fuel pressure 250 -300 kpa. And the mass air flow sensor replaced. TPS seems to be doing what it should and the o2 sensors although test ok i wasnt happy with the results. Anyone got any ideas.
Top
 Profile  
 
 
 Post subject: Re: EL FAIRMONT V8 strange engine behaviour
Posted: Sun Aug 10, 2014 9:12 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Have you replaced the fuel filter?
Top
 Profile  
 
 
 Post subject: Re: EL FAIRMONT V8 strange engine behaviour
Posted: Sun Aug 10, 2014 9:16 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 10

Joined: 23rd Jun 2014

Ride: ford '96 fairmont ghia

Location: campbellfield
VIC, Australia

Yeah mate all filters, oils , plugs leads cap button everything changed during the service i did when i first got it home. As i mentioned even changed thermostat, radiator and all coolant hoses
Top
 Profile  
 
 
 Post subject: Re: EL FAIRMONT V8 strange engine behaviour
Posted: Sun Aug 10, 2014 9:26 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

What condition are the cats in?
Top
 Profile  
 
 
 Post subject: Re: EL FAIRMONT V8 strange engine behaviour
Posted: Sun Aug 10, 2014 10:52 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 10

Joined: 23rd Jun 2014

Ride: ford '96 fairmont ghia

Location: campbellfield
VIC, Australia

While changing the exhaust i paid close attention to checking out the cats. They where clean still had a good honeycomb shape to it.
Prior to changing i had planned to gut the cats but they looked that good i thought id leave them alone.
Adding another thing to make it all a little strange is no fault codes. I have done the old L.E.D test light trick and 782 comes up on the eng off test and the k.o.e.on. test comes up 111.
Top
 Profile  
 
 
 Post subject: Re: EL FAIRMONT V8 strange engine behaviour
Posted: Sun Aug 24, 2014 1:46 pm 
Fordmods Newbie
Offline

Age: 36

Posts: 10

Joined: 23rd Jun 2014

Ride: ford '96 fairmont ghia

Location: campbellfield
VIC, Australia

An update on strange engine behaviour. After not being completely happy with the O2 sensor readings i decided to replace them. Removed the cats to change them and decided to introduce the internals if the cats to my large screwdriver and a hammer. Turns out IF THE CATS LOOK GOOD FROM THE REAR they can be blocked to the s**t at the other end.
So now with clear cats opened exhaust it breathes better sounds better and pulls better. Loving my car once again.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 11:11 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names