Fordmods Logo

Engine noise 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Engine noise
Posted: Tue Feb 07, 2012 8:55 pm 
Fordmods Newbie
Offline

Age: 47

Posts: 2

Joined: 7th Feb 2012

Ride: BA xr8 ute

Location: melbourne
VIC, Australia

Hi there Guys I Have a BA XR8 2004 with Boss 260 5 speed manual
When i start the car there is no noise until it warms a little then there is a constant ticking noise.
When the motor is under load the noise goes away until say you get to a constant speed.
When you get down and listen to it it almost sounds like it coming from the drivers side cylinder head.
I have been told its a stuck lifter , i have been told its a cracked piston , i have been told its chewing out the bottom end .
Any thoughts would be much appreciated thanks for your time Regards Dean :(
Top
 Profile  
 
 
 Post subject: Re: Engine noise
Posted: Mon Feb 13, 2012 10:23 pm 
Stock as a Rock
Offline

Age: 45

Posts: 158

Joined: 30th Jan 2012

Ride: DL LTD

Location: Kallangur
QLD, Australia

Sounds like a dodgy lifter to me...silly question though when was the last time you changed your oil and filter?...Ive had fords that make all kinds of weird ticks and clicks if i used other than a ryco filter or if the oil is too thick/thin. If its a split piston you could pick it up on a compression test although I would have thought you would have had a shyte load more issues if it was that.

 

_________________

Lets just pretend I give a s**t and leave it at that.....

Top
 Profile  
 
 
 Post subject: Re: Engine noise
Posted: Tue Feb 14, 2012 8:51 pm 
Oompa Loompa
Offline
User avatar

Age: 39

Posts: 33

Joined: 3rd Apr 2010

Ride: 1995 XF ute

Location: Burnie
TAS, Australia

got a mate who had a simular problem, turned out to be a injector from our s**t fuel here in tas'.
a bottle of wynns injector cleaner fixed that problem!

cheers
Top
 Profile  
 
 
 Post subject: Re: Engine noise
Posted: Wed Feb 15, 2012 6:23 pm 
Fordmods Newbie
Offline

Age: 28

Posts: 13

Joined: 5th Oct 2011

Gallery: 1 images

Ride: ford falcon xr8 ef2

Location: rotorua
New Zealand

My ef2 96 xr8 was doing the same thing, got a oil change and problem solved.
I was lucky to get it done or else it couldve been worse.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 12:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names