Fordmods Logo

Fbt engine/ computer issues 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: Fbt engine/ computer issues
Posted: Tue Oct 13, 2015 7:15 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 6th Sep 2015

Location: maryborough
QLD, Australia

One for the newer skool then myself... currently having issues with a fbt.. today it may well run sweet as.. but tomm will be near undriveable.. an can be as bad as not even get out the shed.. missing at different revs.. missing at idle.. some times starts like is flooded.. can be so savage it could rip it self off it's mounts.. then next day or so, runs like a dream.. hot.. cold.. wet.. dry.. there is no set pattern to it.. it's just nuts.. have found a code reader for it( yes i'm looking for my own), brings up a p/steer switch( not fitted factory) an egr.. now unplugging egr brings on heavy hunting action, till it stalls.. blanking it off, seamed like rich running, again till finally stalling.. now to go with all the normal stuff was replaced.. plugs, leads, coil, filters, cap, rotor... fuel pressure at rail is steady at 30 psi.. with in range as far as i know.. even while running badly pressure is correct.. so to replace the electric bit on the egr... local ford dealer hasn't heard of a fbt.. let alone the part name... no they don't stock the part, or the whole egr.. i can find a new egr valve.. but not the elec bit( what ever it's called)... HELP!!!! i'm open to any ideas what the hells going on with it.. i've been chasing this issue for ages now, it's just some thing hanging off it i'm sure.. backed up by the code readers cyl testing.. such a shame, it's lovely thing, an often shown, but it's headed for storage if i carn't drive it when i want... yet my classics id drive anywhere in a heart beat.. i don't trust this thing to get me to town.. let alone back.. lol..
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Mon Oct 19, 2015 11:54 am 
Smokin em up
Offline

Age: 37

Posts: 284

Joined: 3rd Mar 2012

Ride: NL Fairlane Ghia V8

Location: Geelong
VIC, Australia

If the EGR valve is disconnected it shouldn't make much if any difference. I removed mine when I fitted an AU manifold that has no provision for EGR and I didn't have it turned off in the tune via a quarterhorse for a while. It made no difference switching it on or off, all it may do is add a little timing assuming that the EGR is jammed open. It certainly won't make it run like crap.

Sounds electrical. MAF maybe?
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Tue Oct 20, 2015 6:00 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 6th Sep 2015

Location: maryborough
QLD, Australia

unplugging mine makes little difference for about a minute.. then the hunting starts, to the point it stalls.. i agree with electrics but which part is causing the issue.. given theres no codes showing other then egr.. which i have since found an ordered, along with new o2 senders.. dissy an tp senders r my next thoughts... i have tried removing the maf.. and again made a big difference to the engine.. even cleaned it while i was at it.. still came back to same running issue..
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Tue Oct 20, 2015 6:06 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 6th Sep 2015

Location: maryborough
QLD, Australia

i'm also looking at the moates quarter horse stuff, not so much the tuning, but the dater logging, an real time logging, to try an find the issue.. anyone know if it is capable of doing that job properly.?? or another that could b used that way..??
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Tue Oct 20, 2015 8:52 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

check your TPS, I have a spare you can try, I am in Sydney though, for what ever that is worth.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Wed Oct 21, 2015 11:36 am 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

I just watched someone else diagnose this. Id go with check the MAF.

Even with TPS busted etc, the car should be able to idle. The one critical sensor in the V8 is the MAF for airflow.

Also make sure that your EGR is closing

Nigel
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Thu Oct 22, 2015 9:27 am 
Smokin em up
Offline

Age: 37

Posts: 284

Joined: 3rd Mar 2012

Ride: NL Fairlane Ghia V8

Location: Geelong
VIC, Australia

And yes you can use the QH to help diagnose issues, cause you can look for sensor values that change or are obviously not where they should be.
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Thu Oct 22, 2015 9:51 am 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Have you checked inside the throttle body/EGR Spacer to make sure that its not leaking coolant?
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Thu Oct 22, 2015 6:20 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 6th Sep 2015

Location: maryborough
QLD, Australia

yesterday the erg position valve showed up.. fitted.. no fix, but it was better, after rechecking the codes, the erg 334 still came up, but it gave a new one being the neutral switch.. odd but any way, few more start stop read codes, stopped an running, it came good.. just as if there was nothing wrong i 1st place, so good it drove like a new car, it hasn't got out of shed in months now, given it has been playing up so much... an heres the kicker, yes it runs sweet as, or it did yesterday, theres no saying it will be today... it's pulled this trick many times before.. i've not tried today as yet.. but gives the proof that every thing it as it should b, just with something odd going on.. does anyone have contact for a aussie supplier of the moates system, i've spoken to the guy in the states, but passed me back to a shop over here... i since found another system which kinda does same stuff, but i'm yet to here back from them...
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Thu Oct 22, 2015 7:06 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Fri Oct 23, 2015 7:16 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 6th Sep 2015

Location: maryborough
QLD, Australia

just updating where it's at now.. egr, evp switch has been fitted, an as per it's best trick run sweet as.. 20km trip in the weee hrs today, sweet as... add 12hr shift, an in heat of the day, it wouldn't crank.. dropped into neutral, cranks fires up.. ( never done that before).. cruising home, an yep startered missing again, now underpower, light or heavy, pulls no issues, cruise an keeps dropping in a miss, then good then miss ect ect.. 02 senders showed an fitted today, again it's run sweet as again, tested the codes looking for what ever it may have found today.. self test, only gave 796 ( power steer switch).. live test gave idle speed controller.. 411 412.. high an low... never had that before either.. yet for now it runs sweetly... my guess not for long as it does... it's like it's just loosing the plot, throwing up random things... thinking of grabbing a dissy next.. as it kind fits the fault.. but still only guessing... ecu having a melt down, got me buggered.. ???? or do i just keep throwing uneeded parts at it, that cost is racking up..
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Fri Oct 23, 2015 7:18 pm 
Fordmods Newbie
Offline

Posts: 6

Joined: 6th Sep 2015

Location: maryborough
QLD, Australia

oooppss yes i'm not loosing any coolant, so pretty sure the erg block is still ok..
Top
 Profile  
 
 
 Post subject: Re: Fbt engine/ computer issues
Posted: Tue Oct 27, 2015 12:37 pm 
EFI Guru
Offline

Age: 52

Posts: 4289

Joined: 5th Nov 2004

Gallery: 28 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

That's sounding so all over the place it could be an intermittent grounding fault. Run a multimeter from the engine block to batt negative and wiggle your ground straps to see if it changes.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 2:57 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names