Fordmods Logo

Fordmods Advertising

Ford 302 Clevo (accidental double post) 


Page 1 of 1 [ 2 posts ] 

 Post subject: Ford 302 Clevo (accidental double post)
Posted: Sat Jan 28, 2006 1:26 pm 
Fordmods Newbie

Age: 47

Posts: 10

Joined: 23rd Jan 2006

Gallery: 4 images

Ride: xy gt

Location: Adelaide
SA, Australia

Hi there peoples i have just fitted at 302 clevo with lumpy cam flattop pistons 465 holley card mech secondaries when u start up it fine but once goes into drive or any gear idle slows down and stalls the car will run under high revs no problem could this also be fuel pump its a standard pump on side of motor ,or carby problem timing is set to 10 Degrees or could dizzy be wrong some how its electronic

(accidental double post)
Posted: Sat Jan 28, 2006 2:02 pm 
Getting Side Ways
User avatar

Age: 78

Posts: 1233

Joined: 7th Apr 2005

Gallery: 7 images

Ride: GTHO PH 1 EF ex chaser

Location: Willow vale, GOLD COAST
QLD, Australia

Vacuum problem with the power valve in the holley see the othewr post :D



Rotten Old Revhead!!! XW GTHO + EF ex cop car (exractors 2.5 cat back zorst !6" Simmons K&N +airbox mods Lowered with Bilstein shocks+Whiteline Bars NEXT THING Swap HO for GTP or Ferrari!

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 5:35 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names