Fordmods Logo

losing fluid from radiator resevoir 2001 XR8 Ute 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Thu Jan 30, 2014 5:10 pm 
Fordmods Newbie
Offline

Age: 62

Posts: 3

Joined: 29th Jan 2014

Ride: Ford AU11 XR8 Ute

Location: tempe
NSW, Australia

ive had a new radiator thermostat water pump,radiator cap fitted cars done 105ks, temp gauge stays in the normal range but after driving it in the day time im finding the next day when I switch it on the warning light for low fluid comes on and when I check it its almost empty,my worry is ive got a tear or a nick in the head gasket? What do you think I need to check on, or rather get my meckanic to check on next? Thanks,AU2forme.
Top
 Profile  
 
 
 Post subject: Re: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Thu Jan 30, 2014 5:36 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

Beg borrow steal a pressure tester...

Fill it up with water and pressurise the system overnight and see if you can find water on the ground the next day... If not it has to be leaking internally... It's not going into the oil?

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Thu Jan 30, 2014 6:36 pm 
Getting Side Ways
Offline

Age: 41

Posts: 4629

Joined: 23rd Nov 2006

Gallery: 4 images

Ride: 5.0 AU's and 5.0 Maverick

Power: 139 rwkw

Location: Sydney West
NSW, Australia

Most likely a corroded timing case cover.

 

_________________

xr6turnip wrote:
More people paid for a ride in a VT commodore then an AU Falcon so the VT is superior.
Based on that fact my Mum is the best around!

Top
 Profile  
 
 
 Post subject: Re: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Thu Jan 30, 2014 10:23 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

also check rear of manifold for coolant leaks, check for cracked heater tap and one thing that took me a while to pin point was leaking coolant between timing cover and block.
Top
 Profile  
 
 
 Post subject: Re: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Sun Feb 02, 2014 12:27 pm 
Fordmods Newbie
Offline

Posts: 15

Joined: 24th Nov 2012

Ride: XR8 ute

Location: Melbourne
VIC, Australia

Yep, I have the same car and my timing cover gasket is slowly leaking.
Also had the heater core leak, which drains around the left chassis rail at the firewall.
Top
 Profile  
 
 
 Post subject: Re: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Mon Feb 03, 2014 10:44 pm 
Fordmods Newbie
Offline

Age: 62

Posts: 3

Joined: 29th Jan 2014

Ride: Ford AU11 XR8 Ute

Location: tempe
NSW, Australia

thanks to all who gave me their time and knowledge Re my radiator reservoir losing fluid ive passed your suggestions to my meckanic and hopefully between him and you guys my problem will be fixed,i will let you all know what he discovers, Thanks again, I so appreciate it, Regards au2forme.
Top
 Profile  
 
 
 Post subject: Re: losing fluid from radiator resevoir 2001 XR8 Ute
Posted: Wed Feb 05, 2014 9:10 pm 
Fordmods Newbie
Offline

Age: 62

Posts: 3

Joined: 29th Jan 2014

Ride: Ford AU11 XR8 Ute

Location: tempe
NSW, Australia

au2forme wrote:
thanks to all who gave me their time and knowledge Re my radiator reservoir losing fluid ive passed your suggestions to my meckanic and hopefully between him and you guys my problem will be fixed,i will let you all know what he discovers, Thanks again, I so appreciate it, Regards au2forme.

Oh does anyone know where I could obtain 'headlight covers' for my Tickford XR8 Ute, 2001 AU11? Thanks, AU2Forme.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:27 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names