Fordmods Logo

low oil pressure 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: low oil pressure
Posted: Sun Jan 30, 2011 2:50 am 
Smokin em up
Offline

Age: 64

Posts: 225

Joined: 9th Nov 2004

Ride: EDV8 Fairmont

Location: perth
WA, Australia

V8 NL Fairlane (wife's car)- dash oil pressure guage drops to zero at idle after oil reaches normal running temp. At higher rpm when driving it is normal. Also normal at start up. No funny clunking noises or overheating.
Oil is valvoline engine armor 15w/40. Oil & filter & sender unit changed - still same result.
Engine has done 240,000kms.
Any ideas - as not too fussed about pulling out engine just to change oil pump.

Richie

 

_________________

1993 ED F/mont 5.0L, Auto, Edelbrock RPM's, CompCam XE276HR, Crane Gold Race 1.7's, Edelbrock Performer, 75mm T/B, MAP, 42lb , GenIII coils, PH4000's , Twin 2.5", Thermos & underspeeds, 3.7 LSD, 2800 stall and MoTec M800, 372fwhp @ 5400rpm & 387 ft-lb @ 4400 rpm.

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sun Jan 30, 2011 5:56 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

didn't windsors take 20w50 standard?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sun Jan 30, 2011 11:10 am 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Yes with that mileage some 20/ 60 will do fine..
Check connections at sender unit nr oil pump or replace it...
It may pay to check with mechanical gauge ?? To be 1000 % sure it has pressure...
Btw it's usually bearings that need replacing...

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sun Jan 30, 2011 3:33 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Could just be low oil. :D

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sun Jan 30, 2011 6:51 pm 
Smokin em up
Offline

Age: 64

Posts: 225

Joined: 9th Nov 2004

Ride: EDV8 Fairmont

Location: perth
WA, Australia

connected mechanical gauge -
At idle when motor hot - the dash guage showed zero pressure - the mechanical showed 25 psi.
At normal running on dash gauge (the thick mark about third of scale ) - mechanical showed 40 psi.
Cold start at idle shows 50 psi.

The new sender that was supplied is ford # EF9D290A ( long black plastic can with 27mm aluminium hex body.
I am not convinced this is correct sender or dash gauge is faulty.

Richie

 

_________________

1993 ED F/mont 5.0L, Auto, Edelbrock RPM's, CompCam XE276HR, Crane Gold Race 1.7's, Edelbrock Performer, 75mm T/B, MAP, 42lb , GenIII coils, PH4000's , Twin 2.5", Thermos & underspeeds, 3.7 LSD, 2800 stall and MoTec M800, 372fwhp @ 5400rpm & 387 ft-lb @ 4400 rpm.

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Tue Feb 01, 2011 11:34 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Going by mech gauge?? You have enough oil pressure..
I would fill with higher visc oil tho...

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Wed Feb 02, 2011 11:28 am 
Smokin em up
Offline

Age: 64

Posts: 225

Joined: 9th Nov 2004

Ride: EDV8 Fairmont

Location: perth
WA, Australia

thanx,
will try Penrite HPR15 or 20.

Richie

 

_________________

1993 ED F/mont 5.0L, Auto, Edelbrock RPM's, CompCam XE276HR, Crane Gold Race 1.7's, Edelbrock Performer, 75mm T/B, MAP, 42lb , GenIII coils, PH4000's , Twin 2.5", Thermos & underspeeds, 3.7 LSD, 2800 stall and MoTec M800, 372fwhp @ 5400rpm & 387 ft-lb @ 4400 rpm.

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Wed Feb 02, 2011 3:03 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

use a 20W/50 oil.

Gab
Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Fri Feb 04, 2011 10:01 pm 
Parts Gopher
Offline
User avatar

Age: 34

Posts: 81

Joined: 7th Jun 2010

Gallery: 3 images

Ride: NL Fairlane V8

Location: Sydney
NSW, Australia

richie wrote:
thanx,
will try Penrite HPR15 or 20.

Richie



Mate, please use the Penrite HPR 20w60 (extra 10)... absolutely perfect oil for my NL Fairlane V8 with 213000kms... I had the same issues about a year ago... I didn't have time to service it so I took it to Ford and I have no idea what they put in it... once at operating temp and it was country driving then, coming to a stop was bad news... oil gauge was going nuts & alarming at me.. had to hold the revs while on the brake pedal to keep the pressure up :lol:

but trust me, Penrite HPR 20w60 (extra 10) is the way to go... 8-)

 

_________________

'98 NL Fairlane Ghia 5.0l

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sat Feb 05, 2011 1:15 pm 
Getting Side Ways
Offline

Age: 48

Posts: 419

Joined: 16th Jan 2005

Ride: EF Ghia 5.0

Location: Adelaide
SA, Australia

+1 on the Penrite 20w60 semi-syn. 210,000 on my Windsor, oil and filter change every 5000-6000km, perfect oil pressure. :)

Mike

 

_________________

EF Ghia 5.0 - XR8 in a tuxedo....classy, low and loud

Bordeaux Purple, Tickford kit, slammed, 18" BA XR8's, EL Ghia chrome, full leather, Pioneer audio, C&C, ABS, LSD, Crane cam, GT40P heads, high flow cats, Genie extractors, lots of woodgrain, chrome and interior lights!

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sat Feb 05, 2011 3:20 pm 
Parts Gopher
Offline
User avatar

Age: 34

Posts: 81

Joined: 7th Jun 2010

Gallery: 3 images

Ride: NL Fairlane V8

Location: Sydney
NSW, Australia

V8 Ghia Mike wrote:
+1 on the Penrite 20w60 semi-syn. 210,000 on my Windsor, oil and filter change every 5000-6000km, perfect oil pressure. :)

Mike


8-) Exactly!!

 

_________________

'98 NL Fairlane Ghia 5.0l

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sun Feb 06, 2011 2:43 pm 
Smokin em up
Offline

Age: 64

Posts: 225

Joined: 9th Nov 2004

Ride: EDV8 Fairmont

Location: perth
WA, Australia

Did oil change - HPR30 ( 20w/60 ).
When hot & at idle it holds at about 30 psi. Does not drop to 0.

Thanx for all that. - I suppose one day it might be lucky to be pulled out for a freshen up!

Richie

 

_________________

1993 ED F/mont 5.0L, Auto, Edelbrock RPM's, CompCam XE276HR, Crane Gold Race 1.7's, Edelbrock Performer, 75mm T/B, MAP, 42lb , GenIII coils, PH4000's , Twin 2.5", Thermos & underspeeds, 3.7 LSD, 2800 stall and MoTec M800, 372fwhp @ 5400rpm & 387 ft-lb @ 4400 rpm.

Top
 Profile  
 
 
 Post subject: Re: low oil pressure
Posted: Sun Feb 06, 2011 4:03 pm 
Parts Gopher
Offline
User avatar

Age: 34

Posts: 81

Joined: 7th Jun 2010

Gallery: 3 images

Ride: NL Fairlane V8

Location: Sydney
NSW, Australia

richie wrote:
Did oil change - HPR30 ( 20w/60 ).
When hot & at idle it holds at about 30 psi. Does not drop to 0.

Thanx for all that. - I suppose one day it might be lucky to be pulled out for a freshen up!

Richie



Awesome!! Did my Lane today too... HPR30 20w60... She purrs :lol:

 

_________________

'98 NL Fairlane Ghia 5.0l

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 3:07 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names