Fordmods Logo

Fordmods Advertising

NF LTD Windsor wont start after intake mods 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: NF LTD Windsor wont start after intake mods
Posted: Thu Aug 18, 2016 8:57 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 18th Aug 2016

Ride: Everything starts with an E

Location: MANDURAH
WA, Australia

I Have a 1997 NF Fairlane LTD V8. I got my hands on an AU XR8 series 3 handbuilt tickford windsor that I will run a carby setup on, in a cortina. So I used the AU XR8 Explorer intake and lower manifold for my 1997 NF LTD. I ported the lower manifold, I ran the 24lbs blue fuel injectors from the XR8. I used the 65mm Throttle Body from the AU and the AU's non EPG spacer plate.

Image

I cant get the windsor to fire even with a spray of starter down the TB

She cranks and cranks but no ignition. Ive checked Fuel and Spark and it has both. It has injector pulse and power out of the dizzy. Fuel is in the lines and in the cylinders.

Am I not running enough fuel pressure from the pump to power the 24lbs injectors?

It all srarted because she was running a stock 302 Windsor with LPG/Petrol. Ran idle high on LPG (about1500rpm), but ran on 6cyls on petrol. I assumed it was stuffed injectors. It had a manifold intake leak somewhere under the inlet manifold and was drawing air. I thought that may be why it idle'd high on LPG.
She now has 40lts of Premium in her tank and gas is disconnected temporarily.

Is there something im missing in the Explorer conversion? Why wont my Windsor fire?
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Thu Aug 18, 2016 9:30 pm 
Oompa Loompa
Offline

Age: 41

Posts: 47

Joined: 15th Jun 2016

Ride: Ef xr6

Location: Boronia
VIC, Australia

Have you double checked all the electrical connections, if you have someone that can turn the key for you try spraying the starter fluid around the inlet manifold as it cranks and see if that makes her try to fire. How strong is the spark and have you checked the Crank Angle Sensor, it may be a coincidence and just happened to die also check harmonic balancer,
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Sat Aug 20, 2016 10:26 am 
EFI Guru
Offline

Age: 51

Posts: 4189

Joined: 5th Nov 2004

Gallery: 24 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

If you have fuel and spark it should fire. You haven't got the dizzy 180 out?
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Sat Aug 20, 2016 3:24 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 18th Aug 2016

Ride: Everything starts with an E

Location: MANDURAH
WA, Australia

Is it possible to have dizzy 180 out?
Has the rotor button moved not the dizzy body?
s**t I didn't think of that.
I Just did new fuel pump, new coil, new dizzy cap and new rotor button.
Ill try the dizzy now, if its not dizzy 180out ill start looking into the fuel rails because I used the NL fuel rails not the AU fuel rails. If it had fuel issue I would expect it to cough and splutter a little of ignition then a supply issue.

I didnt think it was possible to put the dizzy in 180 out but im guessing my rotor button had shifted 180 out I suppose. ..
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Sat Aug 20, 2016 5:51 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 18th Aug 2016

Ride: Everything starts with an E

Location: MANDURAH
WA, Australia

Oh crap...
I think ive got the dizzy timing out and im not firing at the right times.
Im googling how to locate TDC so I can put the dizzy in right.
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Sat Aug 20, 2016 8:27 pm 
EFI Guru
Offline

Age: 51

Posts: 4189

Joined: 5th Nov 2004

Gallery: 24 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

For future reference. Just mark where the rotor was pointing when you pull it apart. Then, if you don't move the crank you can just line it up when you put the dizzy back in.
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Sat Aug 20, 2016 8:32 pm 
EFI Guru
Offline

Age: 51

Posts: 4189

Joined: 5th Nov 2004

Gallery: 24 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

Btw the AU injectors won't run quite right because your EEC doesn't know it has bigger injectors so it will over fuel. Put your stock 19's back in and it'll run spot on.
Also run the 70mm AU MAF if you have it.
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Fri Aug 26, 2016 12:11 am 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 18th Aug 2016

Ride: Everything starts with an E

Location: MANDURAH
WA, Australia

I took the au injectors out and replaced them with a replacement set of orange 19lbs injectors. .. Still no joy, shes not firing although seemed to run on starter spray (could timing be right? )
I'm out of ideas
Why is my Windsor not firing? :(
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Fri Aug 26, 2016 11:19 am 
EFI Guru
Offline

Age: 51

Posts: 4189

Joined: 5th Nov 2004

Gallery: 24 images

Ride: 351 Vogue,XH 5.0,'17 5.0 Stang

Location: Perth
WA, Australia

If it ran on spray but not the injectors, there's no fuel coming out of them. Check that the injectors are getting pulsed.
Top
 Profile  
 
 
 Post subject: Re: NF LTD Windsor wont start after intake mods
Posted: Fri Aug 26, 2016 8:39 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 6

Joined: 18th Aug 2016

Ride: Everything starts with an E

Location: MANDURAH
WA, Australia

I got it running. This LTD'S 302 has low compression on cyls 7 and 8. It has a cracked timing cover and the oil mixes with the coolant. Its time to abandon ship on the NL LTD's 302 windsor in favour of backwards converting the AU XR8 engine into the LTD. ..

Very sad to find such an unhealthy donk at 214,000km's
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 09, 2016 10:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names