Fordmods Logo

Oil Pressure Issues 


Page 1 of 1 [ 2 posts ] 

 Post subject: Oil Pressure Issues
Posted: Sat Aug 04, 2007 1:57 pm 
Oompa Loompa

Age: 32

Posts: 47

Joined: 5th Nov 2004

Gallery: 3 images

Ride: BA XR8 Ute, XD Sedan (not runnin

Location: Adelaide
SA, Australia

Hey guys i have recently purchased a NF Fairlane with a 5 litre in it, and i am having trouble with the oil pressure gauge. I have changed the oil and put a new filter on it, but the gague reads that i have no oil pressure.
On startup on a cold morning the gauge hardly goes up to the halfway mark, then as soon as you start driving it goes down until the warning light comes on. The car still runs fine, no knocks or ticking or clunking. Could the oil pressure sender be crook??



NF Fairlane Series 2
XE S pack Sedan

Posted: Sat Aug 04, 2007 3:27 pm 
Getting Side Ways
User avatar

Age: 63

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Yep change oil sender unit and check motor to body earth, connections at bettery....



As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 8:10 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names