Fordmods Logo

Pursuit Ute problems 

 

Page 1 of 2 [ 19 posts ] Go to page 1, 2  Next

 
 Post subject: Pursuit Ute problems
Posted: Sat Feb 21, 2009 6:09 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

My cousin has a BA Pursuit ute. It's idling really low and stalling when coming to a stop nearly every time. How does one go about adjusting the idle on these puppies?

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sat Feb 21, 2009 7:37 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2058

Joined: 25th May 2006

Ride: ef xr8

Power: 229 rwkw

Location: Perth
WA, Australia

possibly O2 sensor??

 

_________________

Because of Beer, Thirst is a Beautiful Thing!

'95 EF XR8 auto, Advance headers, 3" exhaust, Cobra manifold, BBK 75mm throttle body , 80MM Marauder MAF, Vortech V2 T Trim , 307 rwhp, 405 ft/lb 13.2 @ 105 MPH

Now N/A (permanent Lag) - AFR 165's, Comp XE270 cam, 1.6 RR - 269 rwhp 14.1 @ 102mph.

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sat Feb 21, 2009 7:42 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Maybe, but I don't know whether it would drop the idle to about 500rpm on these. When the aircon is on it drops to about 450rpm. It's pretty f**k up..

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sat Feb 21, 2009 11:27 pm 
Smokin em up
Offline
User avatar

Age: 55

Posts: 219

Joined: 11th Jan 2005

Ride: Pursuit 250

Location: Katoomba
NSW, Australia

If he had the battery disconnected or work done on it then it may be as simple as an ECU reset
Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sun Feb 22, 2009 1:15 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Can we just do an ECU reset or is it something that needs to be done by the workshop?

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sun Feb 22, 2009 3:41 pm 
Smokin em up
Offline
User avatar

Age: 55

Posts: 219

Joined: 11th Jan 2005

Ride: Pursuit 250

Location: Katoomba
NSW, Australia

You can do it yourself but first make sure you have the security code (pin number) for your stereo as it involves disconnecting the battery. This is very slightly over what most will give you but my mate who is still in the business has never had one not sucessful doing it this way.

First turn off any car alarm.
Disconnect the positive terminal of the battery
You can either leave it for an hour and it will reset or you can cheat. The brake wire goes through the ECU so if once you have disconnected the battery you then turn the ignition key all the way to the (on) position then hit the brake a few times this should close that circuit and cheats by causing the ECU to reset .

- When power is re-connected, Turn the ign to (on) and wait for cluster to finish self check then turn off and remove key. Re-insert key again and repeat. After self check is finished start car and idle in this sequence
- 2 minutes idling with the transmission in drive and A/C on.
- 2 minutes idling with the transmission in drive and A/C off.
- 2 minutes idling with the transmission in neutral and A/C on.
- 2 minutes idling with the transmission in neutral and A/C off.
- Drive the car on the road, for at least 10 minutes under variable throttle positions.
Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sun Feb 22, 2009 9:33 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Thanks mate. And if it's manual?

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sun Feb 22, 2009 9:42 pm 
Getting Side Ways
Offline
User avatar

Posts: 686

Joined: 11th Sep 2008

Location: Melbourne
VIC, Australia

hey mate, not sure what those last people were about. Your problem sounds like a TPS problem. And if not then guaranteed to be the throttle body itself. And ba's don't have radio pin either so don't worry bout that.
Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sun Feb 22, 2009 11:03 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Ah ok. Can you tell me how I'd go about checking to see if it's one or the other? Or will it just need a diagnostic scan? You can't adjust the idle manually with these like you can on the Windsors huh?

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Sun Feb 22, 2009 11:51 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2058

Joined: 25th May 2006

Ride: ef xr8

Power: 229 rwkw

Location: Perth
WA, Australia

Fly by wire on the BA throttle bodies?

 

_________________

Because of Beer, Thirst is a Beautiful Thing!

'95 EF XR8 auto, Advance headers, 3" exhaust, Cobra manifold, BBK 75mm throttle body , 80MM Marauder MAF, Vortech V2 T Trim , 307 rwhp, 405 ft/lb 13.2 @ 105 MPH

Now N/A (permanent Lag) - AFR 165's, Comp XE270 cam, 1.6 RR - 269 rwhp 14.1 @ 102mph.

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Mon Feb 23, 2009 12:30 am 
Getting Side Ways
Offline
User avatar

Posts: 686

Joined: 11th Sep 2008

Location: Melbourne
VIC, Australia

yes they have fly by wire. See if you's tps is flat or has a dimple.the revised ones had a dimple instead of being flat. If it's a newer one then i'd put a throttle body on.scan tool won't diagnose this problem
Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Mon Feb 23, 2009 11:31 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

It's an '03 Pursuit... I dare say it's not revised.

So, if there's a problem with the tb, it needs to be replaced cos it's electronically controlled? Stupid bloody electrics

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Mon Feb 23, 2009 12:50 pm 
Getting Side Ways
Offline
User avatar

Posts: 686

Joined: 11th Sep 2008

Location: Melbourne
VIC, Australia

correct^
Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Mon Feb 23, 2009 11:14 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1886

Joined: 26th Nov 2006

Gallery: 7 images

Ride: EL XR8, '08 Mondeo XR5t

Power: 205 rwkw

Location: Perth
WA, Australia

Crap...

 

_________________

Trickflow Street Heat top end kit, 70mm BBK TB & EGR, 24lb injectors, Underdrives & 3.73s: 275rwhp - 13.15@105mph NA / 12.37@116mph N20

When injustice becomes law, resistance becomes duty

Top
 Profile  
 
 
 Post subject: Re: Pursuit Ute problems
Posted: Mon Feb 23, 2009 11:28 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

Give it a good clean first.

The BOSSes (Especially the early ones if they weren't run in hard) can have a bit of oil use, and this (because it's recycled as part of the PCV system) can gum up the TB.

Stock idle is about 550rpm anyway. (higher if it's cold, mine first thing in the morn idles at about 700rpm)

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:34 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names