Fordmods Logo

So whats it it : Bendix ECU/Box above steering wheel 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: So whats it it : Bendix ECU/Box above steering wheel
Posted: Sun Jan 27, 2008 8:06 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Thought it might be an ABS ECU, however my car is sans-abs so that makes no sense. Any other ideas?

Nigel
Top
 Profile  
 
 
Posted: Sun Jan 27, 2008 9:27 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2116

Joined: 13th Aug 2005

Gallery: 15 images

Ride: 1999 XHII XR8, 2002 AU Fairmont

Power: 236 rwkw

Location: Perth
WA, Australia

Bit hard to tell by the way you described it but most likely the TCM, trans control module, guessing that it is a V8.

 

_________________

STREETBUILT RACING
1999 XHII Falcon XR8 Ute 5.0L, TKO600 5spd, KB 2.1L Blower, 6.5psi, 12.2@113mph!!

Top
 Profile  
 
 
Posted: Sun Jan 27, 2008 10:00 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

I'm assuming the model is an EBII.
TCM should be down around the clutch pedal IIRC, and I think they're made by Bosch.
Could be the ABS ECU - the Bendix units do have them separate from the modulator, unlike the later Bosch units which are combined.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Sun Jan 27, 2008 11:46 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Its not the TCM - thats above the handbrake. This is what confuses me a little - Im sure I *dont* have ABS, but I seem to have the ABS ECU

Hmmm
Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 7:43 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 1093

Joined: 29th Nov 2004

Gallery: 15 images

Ride: BA Ford Fairlane V8

Location: Lower Hunter Valley
NSW, Australia

You probably have a bitsa that someone else has modified perhaps?

 

_________________

Interested in a fair go for the Hunter-New England area of NSW?

Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 3:29 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

Check the front left wheel well, should be an ABS module there(the pump and lines etc). Also how many lines coming out of your booster, 3 is ABS, 2 isnt
Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 3:39 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Isnt 3 Not ABS, 2 is?

I have 2 lines coming out, both going to front LHS footwell - I believe the car has the ABS ECU.

But no ABS light (!?)... so I wonder if it might have been disabled.
Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 7:03 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

Nigel wrote:
Isnt 3 Not ABS, 2 is?

I have 2 lines coming out, both going to front LHS footwell - I believe the car has the ABS ECU.

But no ABS light (!?)... so I wonder if it might have been disabled.


3 for abs

2 for front wheels that run independantly
and 1 for both rears which will run together

best be to check for abs go the the passeger footwell as u said and look for teh modulator OR

take teh car up to 60kmh and step on the brakes HARD AS!! if the wheels lock up no abs, if they chatter abs

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 7:27 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Ive already seen the brake hoses going to the modulator.

Like I said, Im sure it has ABS, but I suspect the ECU has been disabled/the LED has been pulled, possibly when the car had 18's on it.

Ive heard, and seen that ABS increases stopping distance often enough - it allows a half-turn of the wheel when it goes off.
Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 8:22 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

For E series/AU I 3 channel (2 front/1 rear) ABS - there are only two lines exiting the mast cyl.
Pulling the bulb won't disable ABS - pulling the ALB fusible link will (well at least in EF/EL's anyway - the 'Check ABS' light stays on). The EA-ED setup looks like to have 2 ign power lines + one line from a fusible link.

The diagnosis connector has two pins, one is used to put the ECU into diagnostic mode, the other is a direct connection to the 'Check ABS' caption. You can connect a meter/test light to the latter, and find out whether you're getting power to the light (in case it's blown)for a few seconds on IGN on, or constantly while IGN stays on.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 8:25 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

The reason that I figured it had been sidabled was that the Bulb doesnt light up at key-on. The Dash Diagnostic (on start) should illuminate it.

Will look into it.

Nigel
Top
 Profile  
 
 
Posted: Mon Jan 28, 2008 8:42 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

It could be likely that the bulb has been removed, because the ECU has failed - which would cause the light to be constantly on, and you'll most likely won't be able to pull any fault codes.
If the car gets checked for rego, it won't pass - hence pulling the bulb.

Not my way of fixing faults, but for a lot of people, it is.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 2:38 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names