Fordmods Logo

Fordmods Advertising

Speedo Not Working 

 

Page 2 of 2 [ 17 posts ] Go to page Previous  1, 2

 
 Post subject: Re: Speedo Not Working
Posted: Tue Jun 14, 2016 8:30 pm 
Smokin em up
Offline
User avatar

Age: 34

Posts: 257

Joined: 24th Jun 2014

Gallery: 4 images

Ride: BA XR6 Turbo

Location: Jamestown
SA, Australia

TurboXR8 wrote:
Yeah I would prefer it to be slightly rich as well. The tune its got now is all because of the speedo not working it messes with the tune and goes to s**t. I'm going to ask my current mechanic if they'd be able to have a look at the ECU and see if they can see anything. Hopefully they do and it can be a simple fix.



Good luck and keep us updated

 

_________________

Current Ride
BA XR6 Turbo, P3 Paint, BP Trim, Fully Stock Mods to Come!
1996 EF Falcon furura, White.
BA XR6 , P3 Paint, BG Trim, crashed in front but thinking of fixing!

BLUE BLOOD
Previous Rides
1997 EL Falcon
1980 Ford Escort

Top
 Profile  
 
 
 Post subject: Re: Speedo Not Working
Posted: Tue Jun 14, 2016 8:32 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 10

Joined: 12th Jun 2016

Ride: BA MK II XR8 ute

Location: Brisbane
QLD, Australia

Will do. Thanks for your help.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 17 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: si2030 and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Jan 24, 2017 10:12 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names