Fordmods Logo

spluttering through gears 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: spluttering through gears
Posted: Mon Oct 24, 2011 3:45 pm 
Fordmods Newbie
Offline

Age: 25

Posts: 3

Joined: 23rd Oct 2011

Ride: ford au xr8 series 3

Location: newcastle
NSW, Australia

my dads au xr8 series 3 has an interminant splutter when leaving lights or taking off from a sloped suurface , when driving easy it will splutter through 1st , 2nd and sometimes 3rd but will stop when powering through revs. have cleaned all filters , plus new leads and new plugs ... any ideas????
Top
 Profile  
 
 
 Post subject: Re: spluttering through gears
Posted: Mon Oct 24, 2011 10:53 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

cleaned the MAF?

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: spluttering through gears
Posted: Fri Oct 28, 2011 3:06 pm 
Tyre Shredder
Offline

Age: 29

Posts: 365

Joined: 22nd Nov 2007

Ride: FG MK2 XR6T

Location: Bexley, Sydney
NSW, Australia

Mine used to splutter big time when taking off.

It was the Oxy sensors....

As dc_todd said, cleaning the MAF wont hurt either.

 

_________________

Formerly LV XR5 Turbo, AU Fairmont Ghia V8 & EBII Fairmont I6.

Now......
Feb 2012 FG MK2 XR6 Turbo
- Manual
- Luxury Pack

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 11:05 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names