Fordmods Logo

T2 te50 trouble starting and now stalling while driving 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: T2 te50 trouble starting and now stalling while driving
Posted: Thu May 12, 2011 10:53 pm 
Fordmods Newbie
Offline
User avatar

Age: 33

Posts: 13

Joined: 21st Apr 2006

Ride: Ford AUII TE50

Location: Drouin
VIC, Australia

Hi my t2 is having trouble starting recently the other day it was really cold it would not stay started had to keep the car moving to keep it started. but this is only sometimes and not only when its cold and not everyday. now tonight it was randomly stalling while driving. i checked fuses etc the negative cable was a little loose i tightened that. fuel filter, dry cell battery and plugs are less than 12 months old (but will be replaced soon (except battery) so that should help). it has done 184,000, high i know, but is it time to replace coils and leads? (if so what brand is good and where can i get a good set?) anything else it could be? all help appreciated, ive had enough!!
thanx
Top
 Profile  
 
 
 Post subject: Re: T2 te50 trouble starting and now stalling while driving
Posted: Thu May 12, 2011 11:04 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Ah the joys of the Windsor! :)
I couldn't read much into your brief description other than to mention the basics such as the ISC or a vacuum hose may have become disconnected.
If it was a lead then you would just have a rougher engine with say, seven cylinders still running.
In my EL, I've had various failures from OEM parts like the TFI module, fuel pump, dirty ISC, fuel filter clogged, knackered MAF, stuffed leads, dud spark plug etc etc and they have all in one way or another caused crappy running. Do you have a mate who you can swap parts with to narrow down what is causing your problem?

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
 Post subject: Re: T2 te50 trouble starting and now stalling while driving
Posted: Fri May 13, 2011 9:18 am 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Sounds to me the car needs a GOOD service ???
When was the fuel filter serviced ???

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
 Post subject: Re: T2 te50 trouble starting and now stalling while driving
Posted: Fri May 13, 2011 5:25 pm 
Tyre Shredder
Offline

Age: 29

Posts: 365

Joined: 22nd Nov 2007

Ride: FG MK2 XR6T

Location: Bexley, Sydney
NSW, Australia

Crank angle sensor? Can cause starting problems and rough running.

 

_________________

Formerly LV XR5 Turbo, AU Fairmont Ghia V8 & EBII Fairmont I6.

Now......
Feb 2012 FG MK2 XR6 Turbo
- Manual
- Luxury Pack

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:22 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names